POJ1328 Radar Installation

1 篇文章 0 订阅

题目网址:
http://poj.org/problem?id=1328

题意:
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

这里写图片描述

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1

题意:
看图,x轴上方是海,下方就是陆地,点是岛屿,问,在x轴上最多要几个圆(雷达),才能把所有的岛屿覆盖。

思路:
以岛屿为圆心,然后在x轴上有一个区间,每一个岛屿都有,交叉区间只要一个雷达。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

struct Range {
    double x;
    double y;
} range[1010];

bool cmp(Range a, Range b) {
    return a.x < b.x;
}

int main() {
    int n, d;
    int CASE = 1;
    while (scanf("%d%d", &n, &d)!=EOF && (n || d)) {
        int k = 0, flag = 0, counter = 1; //flag 为1 表示有不能覆盖的岛屿
        if(d <= 0) {
            flag = 1;
        }
        for(int i = 0; i < n; i++) {
            double x, y;
            cin >> x >> y;
            if(y > d || flag == 1) {
                flag = 1;
            }

            double s1;
            if(y == d)
            {
                s1 = 0;
            }else{
                s1 = sqrt(d*d-y*y);
            }

            range[k].x = min(x*1.0+s1, x*1.0-s1);//求出在x轴的交点
            range[k].y = max(x*1.0+s1, x*1.0-s1);
            k++;
        }
        cout << "Case " << CASE++ << ": ";

        if(flag == 1)
        {
            cout << -1 << endl;
            continue;
        }
        else{
            sort(range, range+k, cmp);//排序
            Range temp = range[0];
            for(int i = 1; i < k; i++)
            {
                if(range[i].x > temp.y)//没有重叠
                {
                    counter++;
                    temp = range[i];
                }
                else if(range[i].y < temp.y)//有重叠
                {
                    temp = range[i];
                }
            }
            cout << counter << endl;
        }
    }
    return 0;
}

路漫漫其修远兮
吾将上下而求索

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值