POJ Ultra-QuickSort

2 篇文章 0 订阅
1 篇文章 0 订阅

题目网址:http://poj.org/problem?id=2299
题目:
Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 51104 Accepted: 18727
Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input

5
9
1
0
5
4
3
1
2
3
0
Sample Output

6
0

题意:一串数组,只能相邻的两个数字交换,求出给一个数组排好序需要交换的次数。

思路:可以证明,需要证明的次数就是数组的逆序数,所以用一个较快的方法求出逆序数就好了。
什么是较快的方法呢?
= =因为正在做二分法专题, 所以就找到了归并排序。

坑点数值的大小是好多9啊,所以最开始以为只要把数组开成long long就好了,可是到WA了好几次之后,才发现需要把交换的次数设置成long long, = =巨坑
详情见代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;

int const maxn = 500010;
long long que[maxn], temp[maxn];
long long num = 0;
void merge_sort(int begins, int ends);

void Merge(int left, int center, int right)//将上一半和下一半的排好序的que数组合并
{
    int i = left;
    int j = center + 1;
    int k = 0;
    while (i <= center && j <= right)
    {
        if (que[i] > que[j])
        {
            temp[k++] = que[j++];
            num += center - i + 1; //直接求出需要交换的次数
        }
        else
        {
            temp[k++] = que[i++];
        }
    }
    while (i <= center)
    {
        temp[k++] = que[i++];
    }
    while (j <= right)
    {
        temp[k++] = que[j++];
    }
    for (i = left, k = 0; i <= right; i++, k++)
    {
        que[i] = temp[k];
    }
}

int main()
{
    int n;

    while(scanf("%d", &n) != EOF && n)
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%lld", &que[i]);
        }
        num = 0;
        merge_sort(0, n-1);

        printf("%lld\n", num);//long long
    }

    return 0;
}

void merge_sort(int begins, int ends)//归并排序,其实就是运用二分思想
{
    if(begins < ends)
    {
        int q = (begins + ends)/2;
        merge_sort(begins, q);
        merge_sort(q+1, ends);
        Merge(begins, q, ends);
    }
}

好啦,每天积累一点,不断进步

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值