poj 2456

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10878 Accepted: 5363
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

5 3
1
2
8
4
9
Sample Output

3
思路:简单的二分,然而题目开始没读懂(英语硬伤),题目大意:有n个栏杆,c只奶牛,问怎样使最小的距离最大.
二分距离,基本上能想到这一点就能做出来了(只要二分不写挂).

#include <cstdio>
#include <cmath>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int n,c,a[100005];
bool check(int x)
{
    int t=1;
    int biao=1;
    for (int i=2;i<=n;i++)
    {
        if (a[i]-a[biao]>=x) {t++;biao=i;
        }
        if (t>=c) return true;
    }
    return false;
}
void readdata()
{
    while (~scanf("%d%d",&n,&c))
    {   
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int l=0;
        int r=a[n]-a[1];
        while (l+1<r)
        {
            int mid=(l+r)>>1;
            if (check(mid)) l=mid;
            else r=mid;
        }
        printf("%d",l);
    }

}
int main()
{
    readdata();
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值