ACM-HDU水题(回忆C++语法)

题目来源:

https://blog.csdn.net/liuqiyao_01/article/details/8477645

HDU 1000 A + B Problem

#include<iostream>
using namespace std;
#include<cstdio>
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{//使用EOF表示输入不为空 
		printf("%d\n",a+b);
	}
	return 0;
}

1089 A+B for Input-Output Practice (I)

同上

1094 A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84553    Accepted Submission(s): 56325


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
 

Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
 

Sample Input
 
 
4 1 2 3 4 5 1 2 3 4 5

#include<cstdio>
using namespace std;
int n,sum=0;
int main()
{
	for(;;)
	{
		if(scanf("%d",&n)==EOF)//有了这个之后,当读取不到n时,自动推出
		  break;
		sum=0;
		int a;
		for(int i=1;i<=n;++i)
		{
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		sum=0;
	}
	
	return 0;
}

1001 Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 546810    Accepted Submission(s): 138807


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
 
 
1 100
 

Sample Output
 
 
1 5050
 
#include<cstdio>
using namespace std;
int n,sum=0;
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		sum=0; 
		for(int i=1;i<=n;++i)
		{
			sum+=i;
		}
		printf("%d\n\n",sum);//题目说了,有一个空行,每一行之间output SUM(n) in one line, followed by a blank line.
	}
	return 0;
}
发现题目太水了,懒得写了


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值