poj 1988 Cube Stacking(带权并查集)

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 22247 Accepted: 7807
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output


题目大意:
       有n个立方体n个栈,一个栈一个立方体,一条线放置,标号与位置相同,第i个标号为i,现在有两类操作:M x y把x所在的立方体栈放在y所在的上面,C x,计算x下面有多少个立方体
解题思路:
        rank[i]表示i所在的集合里有多少个立方体,(只用到根节点rank)。dist[i]表示i到当前栈顶的距离。那么只需要让栈顶做根节点,合并的时候把y合到x上,y栈顶的dist+=x集合的rank(注意只有虽然所有y的子节点距离都增加了,但是这里只更新了y),x栈顶的rank加上y栈顶的rank,就完成了维护。询问C x的时候就是x所在集合的rank-dist[x]-1(dist[x]在求rank的时候用到路径压缩,加上了所有祖先的dist,有种lazy的感觉。。。)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 30000+10;
int fa[maxn];
int rank[maxn];
int dist[maxn];
void init(){
  for(int i = 0; i < maxn; i++)
  {
    fa[i] = i;
    rank[i] = 1;
    dist[i] = 0;
  }
}
int find(int x)
{
  if(x != fa[x])
  {
    int t = fa[x];
    fa[x] = find(fa[x]);
    dist[x] += dist[t];
  }
  return fa[x];
}
void unite(int x,int y)
{
    int faA = find(x);
    int faB = find(y);
    if(faA != faB)
    {
        fa[faB] = faA;
        dist[faB] = rank[faA];
        rank[faA] += rank[faB];
    }
}

int main()
{
  int n;
  while(~scanf("%d",&n))
  {
    init();
    char op;
    while(n--)
    {
      cin >> op;
      int a,b;
      if(op=='M')
      {
        scanf("%d%d",&a,&b);
        unite(a,b);
      }
      else
      {
        scanf("%d",&a);
        int x = find(a);
        printf("%d\n",rank[x]-dist[a]-1);
      }
    }
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值