Happy 2004

滴答滴答---题目链接 

 

Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

 

 

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

 

 

Output

For each test case, in a separate line, please output the result of S modulo 29.

 

 

Sample Input

 

1 10000 0

 

 

Sample Output

 

6 10

 

 

Source

ACM暑期集训队练习赛(六)

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1695 1573 1788 1060 1370 

 

题解

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int quick_mod(int a,int n )
{
    int b = 1;
    while( n > 1 )
    {
        if( n % 2 == 0 )
        {
            a = ( a * a ) % 29;
            n /= 2;
        }
        else
        {
            b = b * a % 29;
            n--;
        }
    }

    return a * b % 29;
}
int main()
{
    int X;
    int a, b, c;
    while(scanf("%d",&X), X )
    {
        a = quick_mod( 2, 2 * X + 1 );
        b = quick_mod( 3, ( X + 1 ) );
        c = quick_mod( 22, ( X + 1 ) );
        printf("%d\n",( a - 1 ) * (( b - 1 ) * 15) * ( c - 1 ) * 18 % 29) ;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值