Elevator

滴答滴答---题目链接 

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 96327    Accepted Submission(s): 52387


 

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

 

Output

Print the total time on a single line for each test case.

 

 

Sample Input

 

1 2 3 2 3 1 0

 

 

Sample Output

 

17 41

 

 

Author

ZHENG, Jianqiang

 

 

Source

ZJCPC2004

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1004 1002 1009 1021 1003 

--------

分析:  一开始在0层,  上升一层6s,下降一层4s, 停的层等待5s

time=上升的楼层*6+下降的楼层*4+停顿次数*5

-----------------------

#include <iostream>
#include<stdio.h>
using namespace std;
const int maxn=1010;
int a[maxn];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int t1=0;
        int t2=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>a[i-1])
                t1+=a[i]-a[i-1];
            else t2+=a[i-1]-a[i];
        }
        cout<<t1*6+t2*4+5*n<<endl;
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值