G - MPI Maelstrom (spfa点1到达所有点的最短时间里面的那个最大的值)

滴答滴答---题目链接

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

题目大意:BIT最近要取会他们的超级计算机,32处理器阿波罗奥德赛与分层通信子系统分布式共享内存的机器(听着很高端大气),瓦伦丁*麦基的顾问杰克*斯威特告诉她基准测试的新系统。(没有明白什么意思)

“因为阿波罗是一个分布的共享内存的机器,内存的访问和交流通信的时间是不统一的”瓦伦丁告诉斯威特。。。。。。(受不了了,这什么破英语,又臭又长还对话!!!!)

直接说这道题的意思算求,就是给一个临街矩阵,这个邻接矩阵因为上三角跟下三角一样,所以只给了下三角,* 号代表两点不相连,然后求出来点1到达所有点的最短时间里面的那个最大的值!!!(直接说多简单啊,还整这么长的的英文,我擦。。。。。)

 

很明显这是一个裸的最短路dij,spfa随便搞都行

#include<algorithm>
#include<queue>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int N=106;
const int inf=0x3f3f3f;
struct st
{
    int y,time;
    st(int y,int time):y(y),time(time) {}
};
vector<st>g[N];
int v[N];
void spfa(int s)
{
    queue<int>Q;
    Q.push(s);
    while(Q.size())
    {
        s=Q.front();
        Q.pop();
        int len=g[s].size();
        for(int i=0; i<len; i++)
        {
            st q=g[s][i];
            if(v[q.y]>v[s]+q.time)
            {
                v[q.y]=v[s]+q.time;
                Q.push(q.y);
            }
        }
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        char s[36];
        int x;
        for(int i=1; i<=n; i++)
        {
            v[i]=inf;
            g[i].clear();
        }
        v[1]=0;
        for(int i=2; i<=n; i++)
            for(int j=1; j<i; j++)
            {
                scanf("%s",s);
                if(s[0]!='x')
                {
                    x=atoi(s);
                    g[i].push_back(st(j,x));
                    g[j].push_back(st(i,x));
                }
            }
        spfa(1);
        int ans=-inf;
        for(int i=1; i<=n; i++)
            ans=max(ans,v[i]);
        printf("%d\n",ans);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值