Coin Changing Problem (最少硬币问题)

滴答滴答---题目链接 

Find the minimum number of coins to make change for n cents using coins of denominations d1, d2,.., dm. The coins can be used any number of times.

Input

n m
d1 d2 ... dm

Two integers n and m are given in the first line. The available denominations are given in the second line.

Output

Print the minimum number of coins in a line.

Constraints

  • 1 ≤ n ≤ 50000
  • 1 ≤ m ≤ 20
  • 1 ≤ denomination ≤ 10000
  • The denominations are all different and contain 1.

Sample Input 1

55 4
1 5 10 50

Sample Output 1

2

 

Sample Input 2

15 6
1 2 7 8 12 50

Sample Output 2

2

 

Sample Input 3

65 6
1 2 7 8 12 50

Sample Output 3

3

继续学习DP算法,感觉一直不开窍啊。。。。

这道题目很经典了,给出m个价值不同的硬币c1、c2……cm,要求找出能够凑出总价为n的方法,在维基上看到大概的思路如下:

简单地理解,就是能够凑出价值i的情况只有两种,一种是不包括硬币cj,一种是包括硬币cj,我们只需要将两种情况相加即可

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
const int inf=0x3f3f3f;
const int maxn=50001;
int c[21];
int dp[maxn];
int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=1; i<=m; i++)
        cin>>c[i];
    for(int i=0; i<=maxn; i++)
        dp[i]=inf;
    dp[0]=0;
    for(int i=1; i<=m; i++)
        for(int j=c[i]; j<=n; j++)
        {
            dp[j]=min(dp[j],dp[j-c[i]]+1);
        }
          cout<<dp[n]<<endl;
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值