K.Bro Sorting
Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 4628 Accepted Submission(s): 2013
Problem Description
Matt’s friend K.Bro is an ACMer.
Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.
Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.
There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .
Input
The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).
The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.
The sum of N in all test cases would not exceed 3 × 106.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.
Sample Input
2 5 5 4 3 2 1 5 5 1 2 3 4
Sample Output
Case #1: 4 Case #2: 1
Hint
In the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.
Source
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)
Recommend
liuyiding | We have carefully selected several similar problems for you: 6447 6446 6445 6444 6443
题意:给一个n,小于10^6,然后给一个1到n的序列进行排序,排序规则:在这n个数中任意选取一个数,若后面相邻的数比它小,则进行交换,一直到遇到比他大的数或到了数组末尾停止交换,这个过程称为一轮交换。 求将这个序列从小到大排序需要经过最少的交换轮次。
思路:每次开始交换排序时选其中最大的数进行,这种排序方法轮次最少。所以可以想到对于序列中的每个数如果后面有比它小的数,就要进行一轮交换排序。故,令sum=0,从数组序列末尾开始,如果前面的数比后面这个数大,交换它俩,并把sum++,最后的sum即为结果。
这题貌似也可以用树状数组记录最小值,进行交换计数;
代码如下:
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#define ll long long
using namespace std;
const int N=1e6+10;
int a[N];
int main()
{
int t;
scanf("%d",&t);
int f=0;
while(t--)
{
int n;
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
int ans=0;
for(int i=n-2; i>=0; i--)
{
if(a[i]>a[i+1])
{
ans++;
swap(a[i],a[i+1]);
}
}
f++;
printf("Case #%d: %d\n",f,ans);
}
return 0;
}