数据结构实验之二叉树二:遍历二叉树

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba

Hint

 

Source

xam

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
typedef struct st
{
    char data;
    struct st *l,*r;
} tree;
char s[55];
int t;
tree *creat()
{
    tree *root;
    if(s[++t]==',')
        root=NULL;
    else
    {
        root=new tree;
        root->data=s[t];
        root->l=creat();
        root->r=creat();
    }
    return root;
}
void zh(tree *root)
{
    if(root)
    {
        zh(root->l);
        printf("%c",root->data);
        zh(root->r);
    }
}
void hou(tree *root)
{
    if(root)
    {
        hou(root->l);
        hou(root->r);
        printf("%c",root->data);

    }
}
int main()
{
    while(~scanf("%s",s))
    {
        tree *root;
        t=-1;
        root=creat();
        zh(root);
        printf("\n");
        hou(root);
        printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值