ACM-ICPC北京赛区2018-Jin Yong’s Wukong Ranking List-闭包传递

Jin Yong was the most famous and popular Chinese wuxia (The one who fight bad people by his Wukong i.e. Wushu and Kongfu) novelist who lived in Hong Kong. Between 1955 and 1972, he wrote 14 novels which earned him a reputation as one of the greatest and most popular Chinese writers. Over 100 million copies of his works have been sold worldwide,not including a countless number of pirated copies. Jin Yong’s works seem to have magic. Once you begin to read a novel of his, you just can’t stop until you finish it.

Last month, Jin Yong passed away at the age of 94. Many Jin Yong’s fans in PKU held a meeting to memorize him. Jin Yong’s fans always like to discuss or argue or even quarrel about whose Wukong are better among the wuxia characters of his novel. During the meeting, this happened again:

Every fans said some words like "Qiao Feng's Wukong is better than Guo Jing's". Obviously, those words may contradict each other and then cause quarrels. As a boring and girlfriendless male programmer of EECS school, you always want to make some things. So you are eager to point out the contradictions as soon as possible. That means, you want to find out the first one whose words contradict the words said by others before him.

Please note that if A is better than B, and B is better than C, then of course A must be better than C.

Input

There are no more than 15 test cases.

For each test case:

The first line is an integer n( 1 <= n <=20), meaning that there are n sentences.

The following n lines are those n sentences which is in the format below:

s1 s2

This means someone said that s1's Wukong was better than s2's. Both s1 and s2 are names of Jin Yong's characters which consists of only English letters. It's guaranteed that s1 and s2 are different, and their length is no more than 30. Names are case sensitive.

Output

For each test case, print the first sentence which cause a contradiction. If there are no contradiction, print 0 instead.

Sample Input

2
BrokenReputation ExtinctNun
HelloLaught EnvelopeNotFlat
6
LandOverWind LonelyLight
FireMonk CutTheForest
CutTheForest LookCrazy
MakeFoxRush LetMeGo
HeroAunt UniqueLand
LookCrazy FireMonk

Sample Output

0
LookCrazy FireMonk

Hint

DON'T try to figure out who are those names in the sample and waste your time.

  • 题意:给出一个n代表有n行,每行两个a,b字符串,代表a的武功高于b,问最早从第几行开始导致前后矛盾,若不矛盾输出0.
  • 思路:这个题可以转化为有向图判定是否能连成环,因为数据比较小,
  • 我是用floyd做的。每加入一条边就判断一下,直到找到开始矛盾为止
  • #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<map>
    using namespace std;
    const int maxn=101;
    struct st
    {
        string l,r;
    
    } a[maxn];
    int mp[maxn][maxn];
    int m;
    map<string,int>q;
    void floyd()
    {
        for(int k=1; k<=m; k++)
            for(int i=1; i<=m; i++)
                for(int j=1; j<=m; j++)
                    if(mp[i][k]&&mp[k][j])
                        mp[i][j]=1;
    
    
    }
    int main()
    {
        int n;
        while(~scanf("%d",&n))
        {q.clear();
            m=0;
            for(int i=1; i<=n; i++)
            {getchar();
                cin>>a[i].l>>a[i].r;
                if(q[a[i].l]==0)
                    q[a[i].l]=++m;
                if(q[a[i].r]==0)
                    q[a[i].r]=++m;
            }
            int flas=0;
            for(int i=1; i<=n; i++)
            {
                floyd();
                if(mp[q[a[i].r]][q[a[i].l]]==1)
                {
                    cout<<a[i].l<<" "<<a[i].r<<endl;
                    flas=1;
                    break;
                }
                mp[q[a[i].l]][q[a[i].r]]=1;
            }
            if(flas==0)
               cout<<0<<endl;
        }
        return 0;
    }

     

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值