Conscription

滴答滴答是---题目链接

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

POJ Monthly Contest – 2009.04.05, windy7926778

#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=50000+5;
int n,m,r;
struct st
{

    int x,y,d;
} a[maxn];
int par[maxn];
bool cmp(st x,st y)
{
    return x.d>y.d;
}
void init()
{
    sort(a+1,a+r+1,cmp);//按d从大到小排列,以满足最大生成树的要求
    for(int i=1; i<=m+n; i++)//初始化并查集
        par[i]=i;
}
int find(int x)
{
    return ( par[x]==x ? x : par[x]=find(par[x]));
}
int kruskal()
{
    int d_sum=0;
    for(int i=1;i<=r;i++)
    {
        int x=find(a[i].x),y=find(a[i].y);
        if(x != y)//找到一条属于最大生成树的新边
        {
            par[y]=x;//合并
            d_sum+=a[i].d;//这条边属于最大生成树,即对应的题目中要使用的“关系”( ‵▽′)ψ
        }
    }
    return d_sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("\n\n%d%d%d",&n,&m,&r);// n个girl , m个boy , r句话
        for(int i=1;i<=r;i++)
        {
            int x,y,d;
            scanf("\n%d%d%d",&x,&y,&d); //girl - x ; boy - y
            a[i].x=x+1,a[i].y=n+1+y;//这样可以确保男女孩的编号必然是不同的
            a[i].d=d;
        }
        init();
        int d_sum=kruskal();
        printf("%d\n",(n+m)*10000 - d_sum);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值