hdu 【1011】Starship Troopers

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15929    Accepted Submission(s): 4256


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7
 

Author
XU, Chuan
 

Source
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 105;

struct Node   //存储所有的房间信息
{
    int bug,brain;
}node[maxn];

bool vis[maxn];      //判断这个房间是否已经计算过
int pre[maxn];       //用该数组构建邻接表
int dp[maxn][maxn];  
int n,m;

struct Edge          //存储所有边,注意边是双向的
{
    int to,next;
}e[1005];

void dfs(int u)      //树形DP,递归得到dp值
{
    vis[u] = true;
    int pe = (node[u].bug+19)/20;
    for(int x = pe; x <= m; x++)
        dp[u][x] = node[u].brain;
    for(int i = pre[u] ; i != -1; i = e[i].next)
    {
        int v = e[i].to;
        if(vis[v]) continue;
        dfs(v);
        for(int k = m; k >= pe; k--)
            for(int j = 1; j + k <= m; j++)
                if(dp[v][j])
                    dp[u][j+k] = max(dp[u][j+k],dp[u][k]+dp[v][j]);
    }
}

int main()
{
    while(scanf("%d%d", &n, &m) != EOF)
    {
        if(n == -1 && m == -1)
            break;
        memset(pre,-1,sizeof(pre));
        memset(dp,0,sizeof(dp));
        memset(vis,false,sizeof(vis));  //初始化不能忘了
        for(int i = 1; i <= n; i++)
            scanf("%d%d",&node[i].bug,&node[i].brain);
        int from,to,tot = 0;
        for(int i = 1; i < n; i++)  //保存双向边
        {
            scanf("%d%d",&from,&to);
            e[tot].to = to;
            e[tot].next = pre[from];
            pre[from] = tot++;
            e[tot].to = from;
            e[tot].next = pre[to];
            pre[to] = tot++;
        }
        if(m == 0)
            printf("0\n");
        else
        {
            dfs(1);
            printf("%d\n",dp[1][m]);
        }
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值