hdu 【1698】 Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25593    Accepted Submission(s): 12778


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1542  1394  1255  1828  1540 

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

const int maxn = 100005;
int val[4*maxn],sumv[4*maxn];   //开4倍空间可以保证不会超空间
int l,r,v;                      //函数需要调用到的全局变量

void build(int o, int L, int R) //递归建树
{
    int M = L + (R - L)/2;
    if(L == R)
    {
        val[o] = 0;             //这里我讲val的值初始化为0
        sumv[o] = 1;
        return ;
    }
    build(o*2, L, M);
    build(o*2+1, M+1, R);
    sumv[o] = sumv[2*o] + sumv[o*2+1];
    val[o] = 0;
}

void maintain(int o, int L, int R)    //因为这里的值已经被改变,所以需要重新维护
{
    int lc = o*2, rc = o*2+1;         
    if(val[o])                        //注意,如果val已经被改变说明这个节点的sum值需要重新计算
        sumv[o] = val[o]*(R-L+1);
    else
    {
        if(R > L)                     //可能该结点不满足,但是子节点已经改变,所以需要重新计算,我就是因为掉了这个错了好几次
            sumv[o] = sumv[lc] + sumv[rc];
    }
}

void pushdown(int o)                  //区间修改已祖先结点为准,但是当前一步已经修改过,这一步仍需要修改,那么我们需要讲上一步修改的值往下放
{
    int lc = 2*o, rc = 2*o+1;
    if(val[o] > 0)
    {
        val[lc] = val[rc] = val[o];
        val[o] = 0;                   //该结点已经被更新过并且已经往下放,所以需要删除标记
    }
}

void update(int o,int L,int R)
{
    if(l <= L && R <= r)
        val[o] = v;
    else
    {
        pushdown(o);
        int M = L + (R - L)/2;
        if(l <= M)
            update(2*o, L, M);
        else
            maintain(2*o, L, M);       //pushdown()之后注意维护
        if(r > M)
            update(2*o+1, M+1, R);
        else
            maintain(2*o+1, M+1, R);   //pushdown()之后注意维护
    }
    maintain(o, L, R);
}

int main()
{
    int T,n,Q;
    scanf("%d", &T);
    for(int i = 1; i <= T; i++)
    {
        scanf("%d%d", &n, &Q);
        build(1,1,n);
        while(Q--)
        {
            scanf("%d %d %d", &l, &r, &v);
            update(1,1,n);
        }
        printf("Case %d: The total value of the hook is %d.\n", i, sumv[1]);  // 直接取根节点即可,并且根节点肯定被更新过
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值