Description
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
/动态规划刚入门0.0,下面是代码,有注释/
在这里插入代码片
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[100005];
int a[105];
int c[105];
int main()
{
int n,m;
while(cin>>n>>m && n&& m){
memset(dp,0,sizeof(dp)); //原始数组要初始化为0
memset(a,0,sizeof(a));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
scanf("%d",&a[i]); //价值
for(int i=1;i<=n;i++)
scanf("%d",&c[i]); //数量
for(int i=1;i<=n;i++){
if(a[i] * c[i] >= m) //这样的条件下可以转换成完全背包问题
for(int j=a[i];j<=m;j++){
dp[j] = max(dp[j],dp[j-a[i]]+a[i]);
}
else{ //这样的情况下可以转换成0/1背包问题,并且用二进制优化,背包九讲里面有0/1背包二进制优化的介绍
int t = c[i];
for(int k=1;k<t;k=k*2){
for(int j=m;j>=k*a[i];j--)
dp[j] = max(dp[j],dp[j-k*a[i]]+k*a[i]);
t-=k;
}
if(t>0)
for(int j=m;j>=t*a[i];j--)
dp[j] = max(dp[j],dp[j-t*a[i]]+t*a[i]);
}
}
int ans=0;
for(int i=1;i<=m;i++)
if(dp[i] == i) //找到满足的条件
ans++;
cout<<ans<<endl;
}
return 0;
}