*寒假水105——Reduced ID Numbers

 

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

 

#include<iostream>
#include<stdio.h>  
#include<memory.h>  

using namespace std;

int stu[302];  
bool bear[1000000];  
int stun,grn,ans;    
  
bool test(int a)  
{  
    int rem,i;  
    memset(bear,0,sizeof(bool)*ans);  
    for(i=0;i<stun;++i)  
    {  
        rem=stu[i]%a;  
        if(bear[rem])  
        {  
            return 0;  
        }  
        else  
        {  
            bear[rem]=1;  
        }  
    }  
    return 1;  
}  
  
int main()  
{  
    cin>>grn;  
    while(grn--)  
    {  
        cin>>stun;  
        for(ans=0;ans<stun;++ans)  
        {  
            cin>>stu[ans];  
        }  
        while(!test(ans))  
        {  
            ++ans;  
        }  
        cout<<ans<<endl;  
    }  
    return 0;  
}

题解:当然是最最最喜欢的暴力搜索啦!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值