[HNU 10052] Sum

Sum
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 1451, Accepted users: 1296
Problem 10052 : No special judgement
Problem description
Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.
 
Input
The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.
 
Output
The output will contain the minimum number N for which the sum S can be obtained.
 
Sample Input
12
Sample Output
7
Judge Tips
The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.
 
Problem Source
ROI 2002

AC:

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <cmath>
using namespace std;

int main()
{
    int n;
    scanf("%d", &n);
    int i = floor(-1 + sqrt(1 + 8 * n)) / 2, sum = i * (1 + i) / 2;
    for (;;)
    {
        if (sum >= n && !((sum - n) & 1))
        {
            printf("%d", i);
            break;
        }
        sum += (++i);
    }
    return 0;
}

这个题还是比较巧妙的,如果需要输出可行的序列,就是一个背包问题了,但是这个题,并不需要输出序列,对于构造的sum序列,每次将一个+变为-,就会减少一个偶数(在原来的值上减去两倍的变符号的值)。所以整体上只需要从n开始向后判断是否和题目给定的n做差得到偶数即可。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值