HDU 6188 Duizi and Shunzi

Duizi and Shunzi

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1795    Accepted Submission(s): 719


Problem Description
Nike likes playing cards and makes a problem of it.

Now give you n integers, ai(1in)

We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate max(s).

Each number can be used only once.
 

Input
The input contains several test cases.

For each test case, the first line contains one integer n( 1n106).
Then the next line contains n space-separated integers ai ( 1ain)
 

Output
For each test case, output the answer in a line.
 

Sample Input
 
 
7 1 2 3 4 5 6 7 9 1 1 1 2 2 2 3 3 3 6 2 2 3 3 3 3 6 1 2 3 3 4 5
 

Sample Output
 
 
2 4 3 2
Hint
Case 1(1,2,3)(4,5,6) Case 2(1,2,3)(1,1)(2,2)(3,3) Case 3(2,2)(3,3)(3,3) Case 4(1,2,3)(3,4,5)
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6275  6274  6273  6272  6271 
           

           

                这道题用贪心来做就好~~
#include<iostream>
#include<cstdio>
using namespace std;
int sum[1000005];
int main()
{
	int n;
	int maxn=0;
	while (cin >> n)
	{
		memset(sum, 0, sizeof(sum));
		for (int s = 0; s < n; s++)
		{
			int w;
			scanf("%d", &w);
			if (w > maxn)
			{
				maxn = w;
			}
			sum[w]++;
		}
		int ans = 0;
		for (int s = 1; s <= maxn; s++)
		{
			int te = sum[s] / 2;
	//		cout << te << endl;
			ans += te;
			sum[s] %= 2;
			if (sum[s]==1&&sum[s + 1] % 2 == 1 && sum[s + 2] > 0)
			{
				ans++;
		//		cout << s << endl;
				sum[s]--;
				sum[s + 1]--;
				sum[s + 2]--;
			}
		}
		cout << ans << endl;
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值