HDU6188 duizi and shunzi

Nike likes playing cards and makes a problem of it. 

Now give you n integers,  ai(1in)ai(1≤i≤n) 

We define two identical numbers (eg:  2,22,2) a Duizi, 
and three consecutive positive integers (eg:  2,3,42,3,4) a Shunzi. 

Now you want to use these integers to form Shunzi and Duizi as many as possible. 

Let s be the total number of the Shunzi and the Duizi you formed. 

Try to calculate  max(s)max(s)

Each number can be used only once. 
InputThe input contains several test cases. 

For each test case, the first line contains one integer n( 1n1061≤n≤106). 
Then the next line contains n space-separated integers  aiai ( 1ain1≤ai≤n
OutputFor each test case, output the answer in a line. 
Sample Input
7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
Sample Output
2
4
3
2


        
  
Hint
Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)



        
 

其实就是个贪心,在可组成顺子的牌数少于两张的时候优先打对子,但是如果顺子的牌的数量超过两张,那么第三张无论如何都要组成顺子。

错了三次,一次没有清数组,一次忘记第一张牌就可以打对子的情况,最后一次是当打出顺子的时候没有对记录数组减一。

#include<iostream>
#include<algorithm>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>

using namespace std;

int p[1000005];
int t[1000005];

int main()
{
	int n;
	while (~scanf("%d",&n))
	{
		memset(t, 0, sizeof(t));
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &p[i]);
			t[p[i]]++;
		}

		sort(p, p + n);

		int last = 0;
		int temp = 0;
		int ans = 0;

		for (int i = 0; i < n; i++)
		{
			if (temp == 0)
			{
				last = p[i];
				temp++;
				if (t[p[i]]>=2)
				{
					ans++;
					t[p[i]] -= 2;
					temp = 0;
					i++;
				}
			}
			else
			{
				if (temp == 2 && last == p[i] - 1)
				{
					ans++;
					temp = 0;
					t[p[i]]--;
					
				}
				else if (t[p[i]] >= 2)
				{
					t[p[i]] -= 2;
					ans++;
					i++;
				}
				else if(last != p[i] - 1)
				{
					temp = 0;
					last = p[i];
					temp++;

				}
				else if (last == p[i] - 1)
				{
					temp++;
					last = p[i];
					t[p[i]]--;

				}
			
			}
				
		}
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值