zoj3261 Connections in Galaxy War

Connections in Galaxy War

Time Limit: 3 Seconds      Memory Limit: 32768 KB

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1



好吧,话说本周是数据结构周,来个数据结构题意思下,表示一年没敲并查集了,今天居然能手动敲出来表示很不可思议……

这个题意思很简单,一个太空网络,n个星球,这些星球中有个战斗力pi,各个星球之间共有m条路,然后由于战斗很惨烈,所以有些路就在战斗中悲剧了,给出一些查询,如果是destroy x y的话,表示x和y之间的路被毁了,如果是query x的话,表示查询x能请到比他战斗力大,而且最大的援军是哪个星球,如果所有能请到的星球战斗力都没比他大,则输出-1.

呃,这题其实一看很复杂,但是如果从后往前查询的话明显就是个并查集了,根节点保存战斗力最大的星球,如果遇到destroy就等于是连接节点,那么起始的图就是原始图经过查询之后还未被destroy的那部分子图。

代码

#include <stdio.h>
#include <vector>
using namespace std;

typedef struct
{
    int v;
    bool del;
}edge;

typedef struct
{
    int ord;
    int x,y;
}order;

order a[50005];
int p[10005];
vector <edge> q[10005];
char str[10];
int ans[50005];
int fn[10005];

int Find(int t)
{
    if (fn[t]==t) return t;
    fn[t]=Find(fn[t]);
    return fn[t];
}

void Comb(int x,int y)
{
    if (p[x]>p[y] || (p[x]==p[y] && x<y))
    {
        fn[y]=x;
    }
    else
    {
        fn[x]=y;
    }
}

void Union(int x,int y)
{
    int t,s;
    t=Find(x);
    s=Find(y);
    if (t==s) return;
    Comb(t,s);
}

int main()
{
    int i,j,n,f,m,x,y,Q,up;
    edge tag;
    f=0;
    while(scanf("%d",&n)!=EOF)
    {
        if (f==1) printf("\n");
        f=1;
        for (i=0;i<n;i++)
        {
            scanf("%d",&p[i]);
            q[i].clear();
        }
        scanf("%d",&m);
        tag.del=0;
        for (i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            tag.v=y;
            q[x].push_back(tag);
            tag.v=x;
            q[y].push_back(tag);
        }
        scanf("%d",&Q);
        for (i=0;i<Q;i++)
        {
            scanf("%s",str);
            if (str[0]=='d')
            {
                scanf("%d%d",&x,&y);
                a[i].ord=1;
                a[i].x=x;
                a[i].y=y;
                for (j=0;j<q[x].size();j++)
                {
                    if (q[x][j].v==y) break;
                }
                q[x][j].del=1;
                for (j=0;j<q[y].size();j++)
                {
                    if (q[y][j].v==x) break;
                }
                q[y][j].del=1;
            }
            else
            {
                scanf("%d",&x);
                a[i].ord=2;
                a[i].x=x;
            }
        }
        for (i=0;i<n;i++)
        {
            fn[i]=i;
        }
        for (i=0;i<n;i++)
        {
            for (j=0;j<q[i].size();j++)
            {
                if (q[i][j].del==0) Union(i,q[i][j].v);
            }
        }
        up=0;
        for (i=Q-1;i>=0;i--)
        {
            if (a[i].ord==1)
            {
                Union(a[i].x,a[i].y);
            }
            else
            {
                x=Find(a[i].x);
                if (p[x]!=p[a[i].x])
                {
                    ans[up++]=x;
                }
                else
                {
                    ans[up++]=-1;
                }
            }
        }
        for (i=up-1;i>=0;i--)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值