HDU - 2444 The Accomodation of Students (判断二分图+匈牙利算法)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8705    Accepted Submission(s): 3830


 

Problem Description

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

 

 

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.
 

 

 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

 

 

Sample Input

 

4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6

 

 

Sample Output

 

No 3

 

 

Source

2008 Asia Harbin Regional Contest Online

 

 

Recommend

gaojie

 

     就是让你先进行判断是否形成二分图,不能的话输出No,能的话输出最大匹配值;

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
vector<int>ed[500];
int coler[500];
int vis[500];
int use[500];
bool dfs(int x, int col) 
{
	//cout << x << " " << col << endl;
	coler[x] = col;
	for (int s = 0; s < ed[x].size(); s++) {	
		if (coler[ed[x][s]] == col)return 0;
		if (coler[ed[x][s]] == 0 && !dfs(ed[x][s], 3 - col))return 0;
	}
	return 1;
}
int find(int x)
{
	for (int s = 0; s < ed[x].size(); s++) {
		if (!vis[ed[x][s]]) {
			vis[ed[x][s]] = 1;
			if (use[ed[x][s]] == 0 || find(use[ed[x][s]]))
			{
				use[ed[x][s]] = x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset(use, 0, sizeof(use));
		memset(vis, 0, sizeof(vis));
		memset(coler, 0, sizeof(coler));
		for (int s = 1; s <= n; s++) {
			ed[s].clear();
		}
		for (int s = 0; s < m; s++) {
			int a, b;
			scanf("%d%d", &a, &b);
			ed[a].push_back(b);
			ed[b].push_back(a);
		}
		int spot = 0;
		for (int s = 1; s <= n; s++) {
			if(coler[s]==0)
				if (!dfs(s, 1)) {
					cout << "No" << endl;
					spot = 1;
					break;
				}
		}
		if (spot) continue;
		int sum = 0;
		for (int s = 1; s <= n; s++) {
			memset(vis,0,sizeof(vis));
			if (coler[s] == 1 && find(s)) {
				sum++;
			}
		}
		cout << sum << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值