1011: Box of Bricks

时间限制: 1 Sec 内存限制: 64 MB

题目描述

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

输入

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. The input is terminated by a set starting with n = 0. This set should not be processed.

输出

For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. Output a blank line after each set.

样例输入

65 2 4 1 7 50

样例输出

Set #1The minimum number of moves is 5.

提示

来源

ZJGSU warmup 1

emm,怎么一天只能发10篇

这道题格式提交问题有点大?不知道是不是我的问题

#include <bits/stdc++.h>
#define cl(x) memset(x,0,sizeof(x))
#define _cl(a,b) memset(a,0,(b+1)<<2)
#define At(x,y) memset(x,y,sizeof x)
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define drep(i,a,b) for(int i=a;i>=b;i--)
#define ll long long
#define pb push_back
#define vct vector
#define pq priority_queue
#define all(x) x.begin(),x.end()
#define int long long
#define fi first
#define se second
//#pragma GCC optimize(2)
using namespace std;
inline int min(int a,int b) {return a<b?a:b;}
inline int max(int a,int b) {return a>b?a:b;}
//map<string,map<string,int> > mp;
//pq <ll,vct<ll>,less<ll> > now,last;
//vct<vct<int> > vt(n+1,vct<int>(m+1,0))
const int inf=0x3f3f3f3f;
const ll INF=0x3f3f3f3f3f3f3f3f;
const ll mod=1e9+7;
const int MOD=998244353;
const int N=1e2+10;

int n,m;
int a[N];


void solve()
{
    int cnt=0;
    while(scanf("%d",&n)!=EOF&&n){
        int sum=0;
        for(int i=1;i<=n;i++){
            cin>>a[i];
            sum+=a[i]; 
        }
        int ans=0,avg=sum/n;
        for(int i=1;i<=n;i++){
            if(a[i]>avg) ans+=a[i]-avg;
        }
        cnt++;
        printf("Set #%d\n",cnt);
        printf("The minimum number of moves is %d.\n\n",ans);
    }
    return ;
}

signed main()
{
//    srand(time(NULL));
//    freopen("2022_XinShengSai_1.in", "r", stdin);
//    freopen("2022_XinShengSai_1.out", "w", stdout);
//    ios::sync_with_stdio(false); 
//    cin.tie(0); cout.tie(0);
    int t;
//    cin>>t;
    t=1;
    while(t--)
    solve();
    
    return 0;
}
/*

*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值