A Walk Through the Forest

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8485 Accepted Submission(s): 3137

Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output
2
4

解题思路:最开始题意理解错了,后来百度才明白不是简单找最短路条数,还要注意当A可以到达B时,如果A到达2的路径比B到达路径的时间长,则选择从B走,这道题我用了狄克斯特拉算法和记忆化搜索,着重讲一下记忆化搜索,记忆化搜索融合了搜索和动态规划的优点,是一种自顶向下的搜索,主要看一下代码

解题代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;


int n, m;
int dp[10005];
int dis[10005], vis[10005];
int map[1005][1005];


void dijstra()
{
    int minv;
    for(int i = 1; i <= n; i++) {
        dis[i] = map[2][i];
        vis[i] = 0;
    }
    vis[2] = 1;
    int k;
    for(int i = 1; i <= n; i++)
    {
        minv = 0x3f3f3f3f;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[j] < minv)
            {
                minv = dis[j];
                k = j;
            }
        }
        if(minv == 0x3f3f3f3f) break;
        vis[k] = 1;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && dis[j] > dis[k] + map[k][j]) {
                dis[j] = dis[k] + map[k][j];
            }
        }
    }

}
int dfs(int m)//记忆化搜索
{
    if(dp[m])//如果已经搜索过则不再搜索,直接返回加上,可以节省时间
    {
        return dp[m];
    }
    for(int i=1;i<=n;i++)
    {
        if(map[m][i]<0x3f3f3f3f&&dis[i]<0x3f3f3f3f&&dis[m]>dis[i])//此前我一直有个疑问,dp[2]=1的作用,dis[2]肯定要走,所以在dp[2]那处加1,这也符合自顶向下的特点
        {
            dp[m]+=dfs(i);
        }
    }
    return dp[m];
}
int main()
{
    while(scanf("%d", &n) && n) {
        scanf("%d", &m);
        int a, b, c;

        memset(map, 0x3f3f3f3f, sizeof(map));
        for(int i = 1; i <= n; i++)
            map[i][i] = 0;
        for(int i = 0; i < m; i++) {
            scanf("%d %d %d", &a, &b, &c);
            map[a][b] = map[b][a] = min(map[a][b], c);
        }
        dijstra();
        memset(dp, 0, sizeof(dp));
        dp[2] = 1;//当遇到2的时候,要有个返回值进行加
        int ans = dfs(1);
        printf("%d\n", ans);
    }

    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值