北大慕课程序设计与算法(二)Boolean Expressions

总时间限制:
1000ms
内存限制:
65536kB
描述
The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.
输入
The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.
输出
For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.
样例输入
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))
样例输出
Expression 1: F
Expression 2: V
Expression 3: V
来源

México and Central America 2004



该题类似于例题表达式求值,,根据不同运算符的优先级,间接递归求解即可,不过要注意数据的输入。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
char str[205];
int ptr=0;
bool exp();
bool item();
bool factor();
bool notexp();
bool exp(){
    bool res=item();
    while(str[ptr]=='|'){
        ptr++;
        res|=item();
    }
    return res;
}

bool item(){
    bool res=factor();
    while(str[ptr]=='&'){
        ptr++;
        res&=factor();
    }
    return res;
}
bool factor(){
    if(str[ptr]=='V'){
        ptr++;
        return true;
    }else if(str[ptr]=='F'){
        ptr++;
        return false;
    }else if(str[ptr]=='('){
        ptr++;
        bool res=exp();
        ptr++;
        return res;
    }else if(str[ptr]=='!'){
        ptr++;
        return notexp();
    }
}
bool notexp(){
    if(str[ptr]=='F'){
        ptr++;
        return true;
    }else if(str[ptr]=='V'){
        ptr++;
        return false;
    }else if(str[ptr]=='('){
        ptr++;
        bool res=exp();
        ptr++;
        return !res;
    }else if(str[ptr]=='!'){
        ptr++;
        bool res=notexp();
        return !res;
    }
}
int main(){
    char c;
    int p=EOF+1;
    int i=0;
    int t=0;
    while(p!=EOF){
        p = scanf("%c",&c);
        if(c=='\n'||p==EOF){
            str[i]=0;
            ptr=0;
            i=0;
            printf("Expression %d: ",++t);
            if(exp())cout<<"V"<<endl;
            else cout<<"F"<<endl;    
        }else if(c!=' '){
            str[i++]=c;
        }
    }
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值