Amusing numbers

Amusing numbers

Description

Amusing numbers are numbers consisting only of digits 5 and 6.Given an integer k , display the kth amusing number.

Input

FIrst line consists of integer N representing number of test cases
Next N lines consist of N integers (1<=k<=10^15)

Output

N lines each displaying corresponding kth amusing number.

Sample Input

2
1
5

Sample Output

5
65

 

找规律打表:
 
#include<stdio.h>
#include<string.h>
int a[50];
int main()
{
	int t,i,j,k;
	long long n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		k=0;
		while(n)
		{
			if(n&1)
			a[k++]=5;
			else
			a[k++]=6;
			n=(n-1)>>1;
		}
		for(i=k-1;i>=0;i--)
		printf("%d",a[i]);
		printf("\n");
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值