hdoj 1385 Minimum Transport Cost 【floyd + 路径记录】



Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8296    Accepted Submission(s): 2166


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 
题意:有n个站,给出所有站之间的花费以及进入每个站的花费,然后给你起点和终点求最小花费并输出路径,若有多个路径满足最小花费输出字典序最小的路径。

思路:floyd + 路径记录。  路径记录有两种方法:一种记录前驱顶点,这道题不适用,我一开始就因为这里错了;二:记录后续的顶点,适用这道题。


注意:起点终点一样的情况,Path输出只有一个。



代码:15ms
floyd + 路径记录
#include <cstdio>
#include <cstring>
#include <stack>
#include <algorithm>
#define INF 1000000+10
using namespace std;
int Map[500][500];
int pre[500][500];
int n;
int b[500];
void getMap()
{
	int c;
	for(int i = 1; i <= n; i++)
	{
		for(int j = 1; j <= n; j++)
		{
			scanf("%d", &c);
			Map[i][j] = c == -1 ? INF : c;
			pre[i][j] = j;//记录i的后面的点 
		}
	}
	for(int i = 1; i <= n; i++)
	scanf("%d", &b[i]);
}
void floyd()
{
	int i, j, k;
	for(k = 1; k <= n; k++)
	{
		for(i = 1; i <= n; i++)
		{
			for(j = 1; j <= n; j++)
			{
				if(Map[i][j] > Map[i][k] + Map[k][j] + b[k])
				{
					Map[i][j] = Map[i][k] + Map[k][j] + b[k];
					pre[i][j] = pre[i][k];//记录并更新j的前驱顶点 
				}
				else if(Map[i][j] == Map[i][k] + Map[k][j] + b[k])
				pre[i][j] = min(pre[i][j], pre[i][k]);//选择后续点中 较小的 			
			}
		} 
	}
}
int main()
{
	int s, e;
	while(scanf("%d", &n), n)
	{
		getMap();
		floyd();
		while(scanf("%d%d", &s, &e), s!=-1||e!=-1)
		{
			int now = pre[s][e];
			printf("From %d to %d :\n", s, e);
			printf("Path: %d", s);
			if(s == e)//起点终点一样 
			{
				printf("\n");
				printf("Total cost : %d\n\n", 0);
				continue;
			}
			while(1)
			{
				printf("-->%d", now);
				if(now == e) break;
				now = pre[now][e];
			} 
			printf("\n");
			printf("Total cost : %d\n\n", Map[s][e]);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值