hdoj 1385 Minimum Transport Cost

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8953    Accepted Submission(s): 2357


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
题意:  有N个城市,然后直接给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。 如果一辆汽车经过特定的城市,必须要交一定的钱(不知道为啥交,反正就是交钱)。 现在要从a城到b城,花费为路径长度之和,如果经过了特定的城市,还要加上过路费!!! 求最小花费,如果有多条路经符合,则输出字典序最小的路径。 题目分析:关键是按照字典序输出字典序最小路径。 假设有 1--->2  2 2--->3  1 1--->3  3 求1到3的最小花费路径. 那么显然后两条路:  1-->3   3 1-->2-->3  3 它们的花费是相同的,但是路径的字典序不同,“123”比“13”字典序要小,所以应当输出1-->2-->3. 用path[i][j]用来保存 i --> j 的最短路径中 i 的最优后驱(即最近),在Floyd三重循环时,一直更新path。
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
int map[1010][1010],path[1010][1010],b[1010];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF,n)
    {
        int i,j,k,c,s,ss,tt;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)//初始化
            {
                scanf("%d",&c);
                if(c!=-1)
                    map[i][j]=c;
                else
                    map[i][j]=INF;
                path[i][j]=j;
            }
        for(i=1;i<=n;i++)
            scanf("%d",&b[i]);
        for(k=1;k<=n;k++)//三重循环
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    s=map[i][k]+map[k][j]+b[k];
                    if(s<map[i][j])//判断是否更新路径
                    {
                        map[i][j]=s;
                        path[i][j]=path[i][k];//记录路径
                    }
                    if(s==map[i][j])//判断是否相同
                    {
                        if(path[i][j]>path[i][k])//相同的话就按字典序选取保存
                            path[i][j]=path[i][k];
                    }
                }
            }
        }
        while(scanf("%d%d",&ss,&tt)!=EOF)
        {
            int k=ss;
            if(ss==-1||tt==-1)
                break;
            printf("From %d to %d :\n",ss,tt);
            printf("Path: %d",ss);
            while(k!=tt)
            {
                printf("-->%d",path[k][tt]);//输出路径
                k=path[k][tt];
            }
            printf("\n");
            printf("Total cost : %d\n\n",map[ss][tt]);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值