hdoj 1059 Dividing 【多重背包】 【母函数】



Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19646    Accepted Submission(s): 5534


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 
题意:两个人收集到数量不一的 价值分别为1, 2, 3, 4, 5, 6的大理石,现在给出每类大理石的个数,问你能否按总价值 来均分这些大理石。

明显的多重背包:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 20000+10 
using namespace std;
int val[MAX];//记录物品i的价值 
int dp[60000+10]; 
int main()
{
	int num[7];
	int sum;//统计总价值 
	int i, j, k;
	int p = 1; 
	while(scanf("%d%d%d%d%d%d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6]) != EOF)
	{
		if(num[1] == 0 && num[2] == 0 && num[3] == 0 && num[4] == 0 && num[5] == 0 && num[6] == 0)
		return 0;
		k = 0;//记录物品数目 
		sum = 0;//记录总价值 
		for(i = 1; i <= 6; i++)//价值 
		{
			sum += num[i] * i;
			for(j = 1; j <= num[i]; j <<= 1)//二进制拆分物品
			{
				val[k++] = j * i;//系数乘以价值 
				num[i] -= j;//减去当前系数 
			}
			if(num[i] > 0)//如果不能正好均分 
			val[k++] = num[i] * i;//当前剩余系数乘以价值 
		} 
        if(sum & 1)
 		{
     		printf("Collection #%d:\n", p++);
			printf("Can't be divided.\n\n");
			continue;
		}
		memset(dp, 0, sizeof(dp));
		sum /= 2;//一半价值 
		for(i = 0; i < k; i++)//01背包
		{
			for(j = sum; j >= val[i]; j--)
			{
				dp[j] = max(dp[j], dp[j-val[i]] + val[i]);
			}
		} 
		printf("Collection #%d:\n", p++);
		if(dp[sum] == sum)//可以装满一半背包 
		printf("Can be divided.\n\n");
		else
		printf("Can't be divided.\n\n");
	}
	return 0;
}

想了想,这题母函数也能做啊;又看看数据傻了绝对TLE,但我就是不服啊,写好后果断TLE。。。

讨论区说是对60取模,表示不理解,虽然过了总感觉没有依据。 还是贴一下吧

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 210000+10
using namespace std;
int c1[MAX], c2[MAX];
int main()
{
	int num[7];
	int sum;//统计总价值 
	int use, k, i, j;
	int p = 1; 
	while(scanf("%d%d%d%d%d%d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6]) != EOF)
	{
		if(num[1] == 0 && num[2] == 0 && num[3] == 0 && num[4] == 0 && num[5] == 0 && num[6] == 0)
		return 0;
		for(i = 1, sum = 0; i <= 6; i++)
		{
			sum += (num[i] * i) % 60;//费解。。。 
		} 
		if(sum & 1)
		{
			printf("Collection #%d:\n", p++);
			printf("Can't be divided.\n\n");
			continue;
		}
		memset(c1, 0, sizeof(c1));
		memset(c2, 0, sizeof(c2));
		for(i = 0; i <= num[1]; i++)
		c1[i] = 1;
		for(i = 2; i <= 6; i++)
		{
			if(num[i] == 0) continue;//没有对应价值的 不用进行下面的运算 
			for(j = 0; j <= sum/2; j++)
			{
				for(k = 0, use = 0; k+j <= sum/2 && use <= num[i]; k += i, use++)
				{
					c2[k+j] += c1[j];
				}
			}
			for(j = 0; j <= sum/2; j++)
			{
				c1[j] = c2[j];
				c2[j] = 0;
			}
		}
		printf("Collection #%d:\n", p++);
		if(c1[sum/2])//可以匹配到 一半 
		printf("Can be divided.\n\n");
		else
		printf("Can't be divided.\n\n");
	}
	return 0;
} 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值