hdoj1059

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8547    Accepted Submission(s): 2329


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source
 

Recommend
JGShining
动态规划当中的多重背包问题。
#include<iostream>
using namespace std;
int dp[60010]; //dp[i]表示一个人能分到i的分数
int num[7]; //num[i]表示得分为i的物品的个数

int main() {
    int t = 1;
    while (cin >> num[1] >> num[2] >> num[3] >> num[4] >> num[5] >> num[6],
            num[1] + num[2] + num[3] + num[4] + num[5] + num[6]) {
        cout << "Collection #" << t++ << ':' << endl;
        int sum = 0;
        for (int i = 1; i <= 6; i++)
            sum += i * num[i];
        if (sum % 2 != 0) {//物品的总分为奇数不能均分
            cout << "Can't be divided.\n\n";
            continue;
        }
        sum /= 2;
        for (int i = 1; i <= sum; i++)//先将数组初始化
            dp[i] = 0;
        for (int i = 0; i <= num[1] && i <= sum; i++)//对分数为1的物品来说,一个人可以分到的物品得分
            dp[i] = 1;
        for (int i = 2; i <= 6; i++) {
            for (int j = sum; j >= 0; j--) {//j要从大到小枚举,否则会重复
                if (dp[j] == 0)//如果分不到分数为j的物品,跳出本轮循环
                    continue;
                for (int k = 1; k <= num[i] && i * k + j <= sum; k++) {
                    if (dp[i * k + j])//i*k+j是递增的,而j是递减的,如果dp[i*k+j]不等于0,说明前面已经得到过这一系列状态
                        break;
                    dp[i * k + j] = 1; //说明其中一个人可以分到这个分数
                }
            }
        }
        if (dp[sum])//输出结果
            cout << "Can be divided.\n\n";
        else
            cout << "Can't be divided.\n\n";
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值