zoj 2100 Seeding 【DFS 判断是否能经过每个点一次遍历完整个图】

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO


题意:给你一个N*M矩阵,里面有 ' S '和' . ',S表示该位置不能走,' . '表示该位置可以走。现在问你能否从左上角出发经过每个点一次遍历完图中所有的' . '(不能重复走一个点)。



AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char Map[8][8];
bool vis[8][8];
int sum;//图中S的数目
int ans;//当前已经遍历的.
int N, M;
bool flag;//标记有没有遍历完全部的.
void getMap()
{
    sum = 0;//统计S数目
    for(int i = 0; i < N; i++)
    {
        scanf("%s", Map[i]);
        for(int j = 0; j < M; j++)
            if(Map[i][j] == 'S') sum++;
    }
}
int move[4][2] = {0,1, 0,-1, 1,0, -1,0};
bool judge(int x, int y)//判断当前位置是否合法
{
    return x >= 0 && x < N && y >= 0 && y < M && Map[x][y] != 'S' && !vis[x][y];
}
void DFS(int x, int y)
{
    //ans++;
    if(ans == N*M - sum)//当前已经遍历完所有.的个数
    {
        flag = true;
        return ;
    }
    for(int i = 0; i < 4; i++)
    {
        int next_x = x + move[i][0];
        int next_y = y + move[i][1];
        if(judge(next_x, next_y))
        {
            vis[next_x][next_y] = true;
            ans++;
            DFS(next_x, next_y);
            ans--;
            vis[next_x][next_y] = false;
        }
        //ans = max(ans, can);
    }
}

int main()
{
    while(scanf("%d%d", &N, &M), N||M)
    {
        getMap();
        ans = 1;
        flag = false;
        memset(vis, false, sizeof(vis));
        vis[0][0] = true;
        DFS(0, 0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值