poj 3450 Corporate Identity 【暴力KMP】

Corporate Identity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5695 Accepted: 2074

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb

IDENTITY LOST

题意:给你N个字符串,让你找出最长的公共子串。若不存在输出IDENTITY LOST,若存在多个长度相等的,输出字典序最小的。

思路:暴力KMP,枚举一个字符串的所有子串,然后判断其它字符串是否包含该子串。若全部包含则更新子串,否则继续枚举下一个子串。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char str[4001][201];
int f[201];
void getfail(char *s)
{
    int len = strlen(s);
    f[0] = f[1] = 0;
    for(int i = 1; i < len; i++)
    {
        int j = f[i];
        while(j && s[i] != s[j])
            j = f[j];
        f[i+1] = s[i]==s[j] ? j+1 : 0;
    }
}
bool find(char *a, char *b)
{
    int la = strlen(a);
    int lb = strlen(b);
    int j = 0;
    for(int i = 0; i < la; i++)
    {
        while(j && a[i] != b[j])
            j = f[j];
        if(a[i] == b[j])
            j++;
        if(j >= lb)
            return true;
    }
    return false;
}
int main()
{
    int N;
    while(scanf("%d", &N), N)
    {
        for(int i = 0; i < N; i++)
            scanf("%s", str[i]);
        int l = strlen(str[0]);
        char ss[201];
        char ans[201];
        memset(ans, '\0', sizeof(ans));
        for(int i = 0; i < l; i++)//枚举起点
        {
            for(int j = i; j < l; j++)//枚举终点
            {
                int p = 0;
                for(int k = i; k <= j; k++)
                    ss[p++] = str[0][k];
                ss[p] = '\0';
                getfail(ss);//失配函数
                bool flag = true;
                for(int k = 1; k < N; k++)
                {
                    if(!find(str[k], ss))//有一个不匹配
                    {
                        flag = false;
                        break;
                    }
                }
                if(flag)
                {
                    if(strlen(ss) > strlen(ans))//比较长度
                        strcpy(ans, ss);
                    else if(strlen(ss) == strlen(ans) && strcmp(ss, ans) < 0)//字典序
                        strcpy(ans, ss);
                }
            }
        }
        if(strlen(ans) == 0)
            printf("IDENTITY LOST\n");
        else
            printf("%s\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值