hdoj 3294 Girls' research 【Manacher算法】【输出最长回文子串 + 字符转化】

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1027    Accepted Submission(s): 389


Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
      
      
b babd a abcd
 

Sample Output
      
      
0 2 aza No solution!
 



题意:给你一个字符op和一个字符串ss(只有小写字母),字符op代表字符串ss中a字符的真身。举个例子——若op是字符b,那么对于字符串abc,它的真身是zab。现在让你找出字符串中的最长回文子串,若长度小于2输出No solution!,否则输出回文子串在原字符串的起点和终点,并输出它对应的真身。若有多个满足条件的子串,输出最先出现的。


思路:构建新串str,在Manacher算法中记录最长回文串的中心字符str[pos]并求出最长回文串的长度len,那么可以推出

回文串在原串起点s = (pos - len + 1) / 2 - 1,终点e = s + len - 1。

接下来就是输出 ss[i]的真身(s <= i <= e)。输出的时候,可以事先求出op字符和a字符的ascll码差值,然后对要输出的字符ss[i]有如下选择

1,ss[i] - 'a' >= t,直接输出ss[i] - t;

2,ss[i] - 'a' <  t,需要输出ss[i] - t + 26。


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 200100
using namespace std;
char ss[MAXN];//原串
int str[MAXN*2];//新串 注意数组大小
int p[MAXN*2];
int pos;//记录回文字符串的中心位置
int Manacher(char *T)
{
    int len = strlen(T);
    int l = 0;
    str[l++] = '@';//防止越界
    str[l++] = '#';
    for(int i = 0; i < len; i++)
    {
        str[l++] = T[i];
        str[l++] = '#';
    }
    str[l] = 0;
    int mx = 0, id = 0;
    int ans = 0;
    for(int i = 0; i < l; i++)
    {
        if(mx > i)//2*id-i 为 i关于id的对称点
            p[i] = min(p[2*id - i], mx-i);
        else
            p[i] = 1;
        //左右延伸
        while(str[i+p[i]] == str[i-p[i]]) p[i]++;
        if(i + p[i] > mx)//找计算p[i+1]用到的id
        {
            mx = i + p[i];
            id = i;
        }
        if(p[i] - 1 > ans)
        {
            ans = p[i] - 1;
            pos = i;
        }
    }
    return ans;
}
int main()
{
    char op; char a[2];
    while(scanf("%s%s", a, ss) != EOF)
    {
        op = a[0];
        int len = Manacher(ss);//求字符串s的 最长回文子串长度
        if(len < 2)
            printf("No solution!\n");
        else
        {
            int s = (pos - len + 1) / 2 - 1;
            int e = (pos - len + 1) / 2 - 1 + len - 1;
            printf("%d %d\n", s, e);
            int t = op - 'a';//记录和字符a相差的值
            for(int i = s; i <= e; i++)
            {
                if(ss[i] - 'a' >= t)
                    printf("%c", ss[i] - t);
                else
                    printf("%c", ss[i] + 26 - t);
            }
            printf("\n");
        }
    }
    return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值