By Recognizing These Guys, We Find Social Networks UsefulTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others)Total Submission(s): 2842 Accepted Submission(s): 708
Problem Description
Social Network is popular these days.The Network helps us know about those guys who we are following intensely and makes us keep up our pace with the trend of modern times.
But how? By what method can we know the infomation we wanna?In some websites,maybe Renren,based on social network,we mostly get the infomation by some relations with those "popular leaders".It seems that they know every lately news and are always online.They are alway publishing breaking news and by our relations with them we are informed of "almost everything". (Aha,"almost everything",what an impulsive society!) Now,it's time to know what our problem is.We want to know which are the key relations make us related with other ones in the social network. Well,what is the so-called key relation? It means if the relation is cancelled or does not exist anymore,we will permanently lose the relations with some guys in the social network.Apparently,we don't wanna lose relations with those guys.We must know which are these key relations so that we can maintain these relations better. We will give you a relation description map and you should find the key relations in it. We all know that the relation bewteen two guys is mutual,because this relation description map doesn't describe the relations in twitter or google+.For example,in the situation of this problem,if I know you,you know me,too.
Input
The input is a relation description map.
In the first line,an integer t,represents the number of cases(t <= 5). In the second line,an integer n,represents the number of guys(1 <= n <= 10000) and an integer m,represents the number of relations between those guys(0 <= m <= 100000). From the second to the (m + 1)the line,in each line,there are two strings A and B(1 <= length[a],length[b] <= 15,assuming that only lowercase letters exist). We guanrantee that in the relation description map,no one has relations with himself(herself),and there won't be identical relations(namely,if "aaa bbb" has already exists in one line,in the following lines,there won't be any more "aaa bbb" or "bbb aaa"). We won't guarantee that all these guys have relations with each other(no matter directly or indirectly),so of course,maybe there are no key relations in the relation description map.
Output
In the first line,output an integer n,represents the number of key relations in the relation description map.
From the second line to the (n + 1)th line,output these key relations according to the order and format of the input.
Sample Input
Sample Output
|
题意:给你一个N个点(这里用字符串表示的)和M条边的无向图,让你求出桥数并输出所有的桥。
裸题,没什么说的。
需要注意1,图不连通时是没有桥的,输出0;2,求桥要小心重边。
AC代码:
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <string>
#include <map>
#include <algorithm>
#define MAXN 10000+10
#define MAXM 400000+10
using namespace std;
struct Edge
{
int from, to, cut, next;
};
Edge edge[MAXM];
int head[MAXN], edgenum;
int low[MAXN], dfn[MAXN];
int dfs_clock;
int N, M;
map<string ,int> fp;
map<int, string> mp;
void init()
{
edgenum = 0;
memset(head, -1, sizeof(head));
}
void addEdge(int u, int v)
{
Edge E1 = {u, v, 0, head[u]};
edge[edgenum] = E1;
head[u] = edgenum++;
}
void getMap()
{
init();
scanf("%d%d", &N, &M);
char a[20], b[20];
fp.clear(), mp.clear();
int k = 0;
for(int i = 1; i <= M; i++)
{
scanf("%s%s", a, b);
if(!fp[a]) fp[a] = ++k;
mp[fp[a]] = a;
if(!fp[b]) fp[b] = ++k;
mp[fp[b]] = b;
addEdge(fp[a], fp[b]);
addEdge(fp[b], fp[a]);
}
}
int bridge;//桥数
void tarjan(int u, int fa)
{
low[u] = dfn[u] = ++dfs_clock;
int have = 1;
for(int i = head[u]; i != -1; i = edge[i].next)
{
int v = edge[i].to;
if(have && v == fa)//处理重边
{
have = 0;
continue;
}
if(!dfn[v])
{
tarjan(v, u);
low[u] = min(low[u], low[v]);
if(low[v] > dfn[u])
{
bridge++;
edge[i].cut = edge[i^1].cut = 1;
}
}
else
low[u] = min(low[u], dfn[v]);
}
}
int num;//看图是否连通
void find_cut(int l, int r)
{
memset(low, 0, sizeof(low));
memset(dfn, 0, sizeof(dfn));
dfs_clock = num = bridge = 0;
for(int i = l; i <= r; i++)
if(!dfn[i]) tarjan(i, -1), num++;
}
void solve()
{
find_cut(1, N);
if(num != 1)//图不连通
{
printf("0\n");
return ;
}
printf("%d\n", bridge);
for(int i = 0; i < edgenum; i+=2)
{
if(edge[i].cut == 1)
printf("%s %s\n", mp[edge[i].from].c_str(), mp[edge[i].to].c_str());
}
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
getMap();
solve();
}
return 0;
}