The Accomodation of StudentsTime Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3743 Accepted Submission(s): 1754
Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.
Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. Proceed to the end of file.
Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
Sample Output
|
题意:有N个学生和M对关系如<a, b>表示a和b互相认识。现在问你能否把这些人分成两组(不能有剩余)且每一组里面的人都不互相认识。
若不可以实现输出No,反之我们就把M对关系中位于不同组的两人安置在一个双人间,问你需要的最大房间数。
思路:判断是否为二分图 + 最大匹配。
邻接表写了一发RE,没发现有bug。直接换了矩阵写。。。
AC代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 201
using namespace std;
int Map[MAXN][MAXN];
int color[MAXN];//染色
int N, M;
bool judge(int u)//判断是否是二分图
{
for(int i = 1; i <= N; i++)
{
if(Map[u][i] == 0) continue;
if(color[u] == color[i]) return false;
if(!color[i])
{
color[i] = 3 - color[u];
if(!judge(i))
return false;
}
}
return true;
}
int match[MAXN];
bool used[MAXN];
int DFS(int u)
{
for(int i = 1; i <= N; i++)
{
if(Map[u][i] == 0) continue;
if(!used[i])
{
used[i] = true;
if(match[i] == -1 || DFS(match[i]))
{
match[i] = u;
return 1;
}
}
}
return 0;
}
void solve()
{
memset(Map, 0, sizeof(Map));
int a, b;
for(int i = 1; i <= M; i++)
{
scanf("%d%d", &a, &b);
Map[a][b] = Map[b][a] = 1;
}
memset(color, 0, sizeof(color));
color[1] = 1;
if(!judge(1))
{
printf("No\n");
return ;
}
int ans = 0;
memset(match, -1, sizeof(match));
for(int i = 1; i <= N; i++)
{
memset(used, false, sizeof(used));
ans += DFS(i);
}
printf("%d\n", ans / 2);
}
int main()
{
while(scanf("%d%d", &N, &M) != EOF)
{
solve();
}
return 0;
}