The Accomodation of Students(二分图的判断+二分图的最大匹配)

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
题意:

将所有人分成两组,每组里不能有相互认识的同学,如果不能分成这样的组输出No,

如果能,则朋友之间相互两两配对,输出最大可配对数;

思路:

染色法判断是否为二分图,匈牙利算法求二分图的最大匹配

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int N = 210;
int e[N][N],color[N],match[N],vis[N];
int n,m;
int Bfs(int x){ //判断是不是二分图 
	memset(color,0,sizeof(color));
	queue<int>p;
	int tem;
	p.push(x);
	color[x]=1;
	while(!p.empty()){
		tem=p.front();
		p.pop();
		for(int i=1;i<=n;i++){
			if(e[tem][i]){ //有连线 
				if(!color[i]){ //没连过线 
					color[i]=-color[tem];//放在对立边集 
					p.push(i);
				}
				else if(color[i]==color[tem]) //非二分图 
				     return 0;
			}
		}
	}
	return 1;
}
int Find(int x){ 
	for(int i=1;i<=n;i++){
		if(!vis[i]&&e[x][i]){
			vis[i]=1;
			if(match[i]==-1||Find(match[i])){
				match[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int F(){
	int ans=0;
	memset(match,-1,sizeof(match));
	for(int i=1;i<=n;i++){
		memset(vis,0,sizeof(vis));
		if(Find(i)) ans++;
	}
	return ans;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		memset(e,0,sizeof(e));
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			e[a][b]=1;
		}
		int flag=Bfs(1);
		if(!flag){
			printf("No\n");
		}
		else printf("%d\n",F());
	}
	return 0;
}

代码二:

#include<stdio.h>
#include<string.h> 
#include<vector>
using namespace std;
const int N = 210;
int col[N],vis[N],match[N];
vector<int>G[N];
void init(int n){
	for(int i=0;i<=n;i++)
	   G[i].clear();
}
int Dfs(int x,int color){
	col[x]=color;
	for(int i=0;i<G[x].size();i++){
		int u=G[x][i];
		if(col[u]==color) return 0;
		if(!col[u]&&!Dfs(u,-color)) return 0;
	}
	return 1;
}
int cheak(int n){
	memset(col,0,sizeof(col));
	int flag=0;
	for(int i=1;i<=n;i++){
		if(!col[i]){
			if(!Dfs(i,1)){
				flag=1;
				break;
			}
		}
	}
	if(flag) return 0;
	else return 1;
}
int Find(int x){
	for(int i=0;i<G[x].size();i++){
		int u=G[x][i];
		if(!vis[u]){
			vis[u]=1;
			if(match[u]==-1||Find(match[u])){
				match[u]=x;
				return 1;
			}
		}
	}
	return 0;
}
int solve(int n){
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i=1;i<=n;i++){
		memset(vis,0,sizeof(vis));
		ans+=Find(i);
	}
	return ans;
}
int main(){
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF){
		init(n);
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			G[a].push_back(b);
		}
		int flag=cheak(n);
		if(!flag) printf("No\n");
		else printf("%d\n",solve(n));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值