hdoj 3306 Another kind of Fibonacci 【矩阵快速幂】



Another kind of Fibonacci

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2027    Accepted Submission(s): 801


Problem Description
As we all known , the Fibonacci series : F(0) = 1, F(1) = 1, F(N) = F(N - 1) + F(N - 2) (N >= 2).Now we define another kind of Fibonacci : A(0) = 1 , A(1) = 1 , A(N) = X * A(N - 1) + Y * A(N - 2) (N >= 2).And we want to Calculate S(N) , S(N) = A(0) 2 +A(1) 2+……+A(n) 2.

 

Input
There are several test cases.
Each test case will contain three integers , N, X , Y .
N : 2<= N <= 2 31 – 1
X : 2<= X <= 2 31– 1
Y : 2<= Y <= 2 31 – 1
 

Output
For each test case , output the answer of S(n).If the answer is too big , divide it by 10007 and give me the reminder.
 

Sample Input
      
      
2 1 1 3 2 3
 

Sample Output
      
      
6 196
 


1A!\(^o^)/~

题意这么直,就不说了。


由题意可以得到递推公式:

一、A[N]^2 = X^2 * A[N-1]^2 + Y^2 * A[N-2]^2 + 2*X*Y*A[N-1]*A[n-2];

二、S[N] = S[N-1] + A[N]^2; 

三、A[N]*A[N-1] = X * A[N-1]^2 * A[N-2] 。


构造矩阵:




建好矩阵就可以直接KO了。


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MOD 10007
#define LL long long
using namespace std;
struct Matrix
{
    LL a[5][5];
};
Matrix ori, res;
void init(LL x, LL y)
{
    memset(ori.a, 0, sizeof(ori.a));
    memset(res.a, 0, sizeof(res.a));
    for(int i = 0; i < 4; i++)
        res.a[i][i] = 1;
    ori.a[1][0] = ori.a[3][3] = 1;
    ori.a[0][1] = ori.a[0][3] = y*y%MOD;
    ori.a[1][1] = ori.a[1][3] = x*x%MOD;
    ori.a[1][2] = x % MOD;
    ori.a[2][2] = y % MOD;
    ori.a[2][1] = ori.a[2][3] = 2*x*y%MOD;
}
LL F[5];
Matrix muitl(Matrix x, Matrix y)
{
    Matrix z;
    memset(z.a, 0, sizeof(z.a));
    for(int i = 0; i < 4; i++)
    {
        for(int k = 0; k < 4; k++)
        {
            if(x.a[i][k] == 0) continue;
            for(int j = 0; j < 4; j++)
                z.a[i][j] = (z.a[i][j] + (x.a[i][k] * y.a[k][j]) % MOD) % MOD;
        }
    }
    return z;
}
void solve(int n)
{
    while(n)
    {
        if(n & 1)
            res = muitl(ori, res);
        ori = muitl(ori, ori);
        n >>= 1;
    }
    LL ans = 0;
    for(int i = 0; i < 4; i++)
        ans = (ans + (F[i] * res.a[i][3]) % MOD) % MOD;
    printf("%lld\n", ans);
}
int main()
{
    F[0] = F[1] = F[2] = 1; F[3] = 2;
    int N;
    LL x, y;
    while(scanf("%d%lld%lld", &N, &x, &y) != EOF)
    {
        init(x, y);
        solve(N-1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值