hdoj 5476 Explore Track of Point 【托勒密定理】



Explore Track of Point

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 279    Accepted Submission(s): 109


Problem Description
In Geometry, the problem of track is very interesting. Because in some cases, the track of point may be beautiful curve. For example, in polar Coordinate system, ρ=cos3θ  is like rose,  ρ=1sinθ  is a Cardioid, and so on. Today, there is a simple problem about it which you need to solve.

Give you a triangle  ΔABC  and AB = AC. M is the midpoint of BC. Point P is in  ΔABC  and makes  min{MPB+APC,MPC+APB} maximum. The track of P is  Γ . Would you mind calculating the length of  Γ ?

Given the coordinate of A, B, C, please output the length of  Γ .
 

Input
There are T ( 1T104 ) test cases. For each case, one line includes six integers the coordinate of A, B, C in order. It is guaranteed that AB = AC and three points are not collinear. All coordinates do not exceed  104  by absolute value.
 

Output
For each case, first please output "Case #k: ", k is the number of test case. See sample output for more detail. Then, please output the length of  Γ  with exactly 4 digits after the decimal point.
 

Sample Input
      
      
1 0 1 -1 0 1 0
 

Sample Output
      
      
Case #1: 3.2214
 


队友提交WA9次,就因为两个变量写错了 ( ˇˍˇ )


给你一个等腰三角形ABC其中AB = AC,点M为底边中点。

现在让你找一个在三角形ABC内部的点P使  {∠MPB+∠APC,∠MPC+∠APB} 的最小值最大,问你P点的轨迹长度是多少。


渣渣猜答案,大牛用定理证答案。


证明:


ans = 三角形中线长度AM + 过三角形内心(原O与AM交点)、B和C三点的圆弧BC。


AC代码:


#include <cstdio>
#include <cmath>
#define PI acos(-1.0)
int main()
{
    int t, k = 1;
    scanf("%d", &t);
    double ax, ay, bx, by, cx, cy;
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf", &ax, &ay, &bx, &by, &cx, &cy);
        double a = sqrt((bx - cx) * (bx - cx) + (by - cy) * (by - cy));
        double b = sqrt((ax - cx) * (ax - cx) + (ay - cy) * (ay - cy));
        double c = sqrt((ax - bx) * (ax - bx) + (ay - by) * (ay - by));
        double h = sqrt(b*b - a*a/4);
        double angA = acos((b*b + c*c - a*a) / (2.0*c*b));
        double r = tan(angA / 2.0) * c;
        printf("Case #%d: %.4lf\n", k++, r*(PI - angA) + h);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值