hdoj 5463 Clarke and minecraft 【简单贪心】



Clarke and minecraft

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 534    Accepted Submission(s): 276


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a game player of minecraft. 
On that day, Clarke set up local network and chose create mode for sharing his achievements with others. Unfortunately, a naughty kid came his game. He placed a few creepers in Clarke's castle! When Clarke returned his castle without create mode, creepers suddenly blew(what a amazing scene!). Then Clarke's castle in ruins, the materials scattered over the ground. 
Clark had no choice but to pick up these ruins, ready to rebuild. After Clarke built some chests(boxes), He had to pick up the material and stored them in the chests. Clarke clearly remembered the type and number of each item(each item was made of only one type material) . Now Clarke want to know how many times he have to transport at least. 
Note: Materials which has same type can be stacked, a grid can store 64 materials of same type at most. Different types of materials can be transported together. Clarke's bag has 4*9=36 grids.
 

Input
The first line contains a number  T(1T10) , the number of test cases. 
For each test case: 
The first line contains a number  n , the number of items. 
Then  n  lines follow, each line contains two integer  a,b(1a,b500) a  denotes the type of material of this item,  b  denotes the number of this material.
 

Output
For each testcase, print a number, the number of times that Clarke need to transport at least.
 

Sample Input
      
      
2 3 2 33 3 33 2 33 10 5 467 6 378 7 309 8 499 5 320 3 480 2 444 8 391 5 333 100 499
 

Sample Output
      
      
1 2 Hint: The first sample, we need to use 2 grids to store the materials of type 2 and 1 grid to store the materials of type 3. So we only need to transport once;
 



题意:有N份物品,每组输入两个数a和b,a表示物品类型,b表示件数。已知同一类的物品才可以堆在一起。每个格子最多可以堆放64件同一类型的物品,每一次搬运可以携带36个格子,问你运完N份物品需要的最少次数。



思路:建立一个map映射,设置一个变量用作下标来存储类型,统计每个类型的数目,最后贪心的模拟一次就ok了。



AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
int type[510];
map<int, int> fp;
int main()
{
    int t, N;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &N);
        memset(type, 0, sizeof(type));
        fp.clear();
        int cnt = 0;
        for(int i = 1; i <= N; i++)
        {
            int a, b;
            scanf("%d%d", &a, &b);
            if(!fp[a])
            {
                fp[a] = ++cnt;
                type[fp[a]] = b;
            }
            else
                type[fp[a]] += b;
        }
        int ans = 0;
        for(int i = 1; i <= cnt; i++)
        {
            ans += type[i] / 64;
            if(type[i] % 64)
                ans++;//总格数
        }
        printf("%d\n", ans % 36 == 0 ? ans / 36 : (ans / 36 + 1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值