hdoj 5501 The Highest Mark 【贪心 + 0-1背包】



The Highest Mark

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 324    Accepted Submission(s): 129


Problem Description
The SDOI in  2045  is far from what it was been  30  years ago. Each competition has  t  minutes and  n  problems.

The  ith  problem with the original mark of  Ai(Ai106) ,and it decreases  Bi  by each minute. It is guaranteed that it does not go to minus when the competition ends. For example someone solves the  ith  problem after  x  minutes of the competition beginning. He/She will get  AiBix  marks.

If someone solves a problem on  x  minute. He/She will begin to solve the next problem on  x+1  minute.

dxy who attend this competition with excellent strength, can measure the time of solving each problem exactly.He will spend  Ci(Cit)  minutes to solve the ith problem. It is because he is so godlike that he can solve every problem of this competition. But to the limitation of time, it's probable he cannot solve every problem in this competition. He wanted to arrange the order of solving problems to get the highest mark in this competition.
 

Input
There is an positive integer  T(T10)  in the first line for the number of testcases.(the number of testcases with  n>200  is no more than  5 )

For each testcase, there are two integers in the first line  n(1n1000)  and  t(1t3000)  for the number of problems and the time limitation of this competition.

There are  n  lines followed and three positive integers each line  Ai,Bi,Ci . For the original mark,the mark decreasing per minute and the time dxy of solving this problem will spend.


Hint:
First to solve problem  2  and then solve problem  1  he will get  88  marks. Higher than any other order.
 

Output
For each testcase output a line for an integer, for the highest mark dxy will get in this competition.
 

Sample Input
      
      
1 4 10 110 5 9 30 2 1 80 4 8 50 3 2
 

Sample Output
      
      
88
 


题意:给出n道题和每道题的分值、每分钟减少的分值、解决该问题需要的时间,问你在时限m分钟内,可以得到的最大分值。假设你可以解决所有问题。



思路:以为就是0-1背包,没想到测试数据都不过,加个贪心预处理一下就ok了。对于每道题,可选择做或不做,得到状态转移方程dp[j] = max(dp[j], dp[j-num[i].C] + num[i].A - j*num[i].B) (0 <= j <= m)。



AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 3000+10
#define INF 0x3f3f3f3f
using namespace std;
int dp[MAXN];
struct rec{
    int A, B, C;
};
rec num[1010];
bool cmp(rec a, rec b){
    return a.B * b.C > a.C * b.B;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m;
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
            scanf("%d%d%d", &num[i].A, &num[i].B, &num[i].C);
        sort(num, num+n, cmp);
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i < n; i++)
            for(int j = m; j >= num[i].C; j--)
                dp[j] = max(dp[j], dp[j-num[i].C] + num[i].A - j * num[i].B);
        int ans = 0;
        for(int i = 0; i <= m; i++)
            ans = max(dp[i], ans);
        printf("%d\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值