hdoj 5504 GT and sequence 【脑子 抽了】



GT and sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 29


Problem Description
You are given a sequence of  N  integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than  2631 .
 

Input
In the first line there is a number  T  (test numbers).

For each test,in the first line there is a number  N ,and in the next line there are  N  numbers.

1T1000
1N62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output the answer.
 

Sample Input
      
      
1 3 1 2 3
 

Sample Output
      
      
6
 



题意:给出N个数,让你至少选择其中一个数,使得选出的所有数乘积最大,输出最大乘积。


输出没有带Case,可我却加上了。无脑,找了好几分钟才发现。o(╯□╰)o


枚举所有情况,弱渣写的代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define LL __int64
using namespace std;
LL a[1010];
bool cmp(LL a, LL b){
    return a > b;
}
int main()
{
    int t, k = 1;
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        LL sum = 1; LL b;
        int top = 0;
        bool flag = false;//标记是否全为0
        bool have = false;//标记是否出现正数
        bool zero = false;//标记是否出现0
        for(int i = 0; i < n; i++)
        {
            scanf("%I64d", &b);
            if(b)
                flag = true;
            if(b == 0)
                zero = true;
            if(b > 0)
            {
                have = true;
                sum *= b;
            }
            if(b < 0)
                a[top++] = -b;
        }
        if(!flag)//全为0
        {
            printf("0\n");
            continue;
        }
        sort(a, a+top, cmp);
        if(!have)//没有出现正数
        {
            if(top == 1)
            {
                if(zero)
                    sum = 0;
                else
                    sum = -a[0];
            }
            else
            {
                if(top & 1)
                    top -= 1;
                for(int i = 0; i < top; i++)
                    sum *= a[i];
            }
            printf("%I64d\n", sum);
        }
        else
        {
            if(top & 1)
                top -= 1;
            for(int i = 0; i < top; i++)
                sum *= a[i];
            printf("%I64d\n", sum);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值