GT and sequence 5504GT and sequence




Sample Input



Accepts: 95


Submissions: 1467


Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description

You are given a sequence of NNN integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that the absolute value of any product of the numbers you choose in the initial sequence will not bigger than 263−12^{63}-12631.

Input

In the first line there is a number TTT (test numbers).

For each test,in the first line there is a number NNN,and in the next line there are NNN numbers.

1≤T≤10001 \leq T \leq 10001T1000 1≤N≤621 \leq N \leq 621N62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

Output

For each test case,output the answer.

Sample Input
1
3
1 2 3
Sample Output
6


题意:

从N个数中,任意取使乘积最大;


正数肯定全部取,负数存一个数组然后排序,两个两个的取

最后分情况输出 判断负数个数是否大于2 ;

                        如果只有一个负数,输出负数

                       还有输出0的情况,只有一个负数和0



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

__int64 a[100],b[100];
int main()
{
    int t,n;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        __int64 x,sum=1,ans =1;
        int k1=0,k2=0,flag =0;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&x);
            if(x > 0)
                a[k1++] = x;
            else if(x < 0)
                b[k2++] = x;
            else
                flag = 1;
        }
        sort(a,a+k1);
        sort(b,b+k2);
        if(k1 > 0)
        {
            for(int i=0;i<k1;i++)
                sum = sum * a[i];
        }
        if(k2 > 1)
        {
            for(int i=0;i<k2-1;i+=2)
                ans = ans * b[i] * b[i+1];
        }
        if(k1 > 0 )
        {
            if(k2 > 1)
                printf("%I64d\n", sum*ans);
            else
                printf("%I64d\n", sum);
        }
        else
        {
            if(k2 > 1 )
                printf("%I64d\n", ans);
            else if(k2 <=1 && flag )
                printf("0\n");
            else if(k2 <= 1 && flag == 0)
                printf("%I64d\n", b[0]);
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值