hdoj 5505 GT and numbers 【判断一个数 能否通过累乘因子得到另一个数】【好题】



GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 71    Accepted Submission(s): 18


Problem Description
You are given two numbers  N  and  M .

Every step you can get a new  N  in the way that multiply  N  by a factor of  N .

Work out how many steps can  N  be equal to  M  at least.

If N can't be to M forever,print  1 .
 

Input
In the first line there is a number  T . T  is the test number.

In the next  T  lines there are two numbers  N  and  M .

T1000 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
      
      
3 1 1 1 2 2 4
 

Sample Output
      
      
0 -1 1
 



题意:给你两个数N和M,每次操作——N可以乘上它的一个因子变成新的N。问你N能否经过一些操作得到M,若可以输出最少操作次数,否则输出-1。


思路:每次乘gcd(N, M),然后判断N和M是否互质 或者 N是否已经超过M,满足其中一个限制就跳出,反之累加操作次数。 


注意:M <= 2^63,所以不能用long long 或者 __int64,需要用unsigned long long。


AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define LL unsigned long long
using namespace std;
LL gcd(LL a, LL b){
    return b == 0 ? a : gcd(b, a%b);
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        LL N, M;
        scanf("%I64u%I64u", &N, &M);
        if(M < N || M % N)
            printf("-1\n");
        else if(M == N)
            printf("0\n");
        else
        {
            LL time = 0;
            bool flag = true;
            while(N != M)
            {
                LL temp = gcd(N, M / N);
                if(temp == 1 || N > M)//互质 或者 N超过M
                {
                    flag = false;
                    break;
                }
                N *= temp;
                time++;
            }
            if(flag)
                printf("%I64u\n", time);
            else
                printf("-1\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值