GT and numbersTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 71 Accepted Submission(s): 18
Problem Description
You are given two numbers
N
and
M
.
Every step you can get a new N in the way that multiply N by a factor of N . Work out how many steps can N be equal to M at least. If N can't be to M forever,print −1 .
Input
In the first line there is a number
T
.
T
is the test number.
In the next T lines there are two numbers N and M . T≤1000 , 1≤N≤1000000 , 1≤M≤263 . Be careful to the range of M. You'd better print the enter in the last line when you hack others. You'd better not print space in the last of each line when you hack others.
Output
For each test case,output an answer.
Sample Input
Sample Output
|
题意:给你两个数N和M,每次操作——N可以乘上它的一个因子变成新的N。问你N能否经过一些操作得到M,若可以输出最少操作次数,否则输出-1。
思路:每次乘gcd(N, M),然后判断N和M是否互质 或者 N是否已经超过M,满足其中一个限制就跳出,反之累加操作次数。
注意:M <= 2^63,所以不能用long long 或者 __int64,需要用unsigned long long。
AC代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define LL unsigned long long
using namespace std;
LL gcd(LL a, LL b){
return b == 0 ? a : gcd(b, a%b);
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
LL N, M;
scanf("%I64u%I64u", &N, &M);
if(M < N || M % N)
printf("-1\n");
else if(M == N)
printf("0\n");
else
{
LL time = 0;
bool flag = true;
while(N != M)
{
LL temp = gcd(N, M / N);
if(temp == 1 || N > M)//互质 或者 N超过M
{
flag = false;
break;
}
N *= temp;
time++;
}
if(flag)
printf("%I64u\n", time);
else
printf("-1\n");
}
}
return 0;
}