hdoj 2509 Be the Winner 【博弈】



Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2705    Accepted Submission(s): 1478


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
      
      
2 2 2 1 3
 

Sample Output
      
      
No Yes
 



题意:n堆苹果,每次可以取任意一堆里任意数量的苹果,最后取完所有苹果的是失败者。双方都用最优策略,若先手赢输出Yes,反之No。


以前做过类似的题目,但还是WA了3次  o(╯□╰)o

注意:全为1的情况。


AC代码:



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#define MAXN 32000+1
#define MAXM 100000+10
#define INF 0x3f3f3f3f
#define LL long long
#define debug printf("1\n");
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int main()
{
    int N;
    while(scanf("%d", &N) != EOF)
    {
        int num;
        int ans = 0;
        bool flag = false;
        for(int i = 0; i < N; i++)
        {
            scanf("%d", &num);
            ans ^= num;
            if(num != 1)
                flag = true;
        }
        if(!flag)//坑死 全为1。。。
        {
            if(N & 1)
                printf("No\n");
            else
                printf("Yes\n");
        }
        else
        {
            if(ans)
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值