HDOJ 2509 Be the Winner (反尼姆博弈)

Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2718    Accepted Submission(s): 1487


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
  
  
2 2 2 1 3
 

尼姆博弈的一个变形,需要注意的点在代码中标记出来了


Sample Output
  
  
No Yes ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100010
#define MAX(a,b) a>b?a:b
using namespace std;
int main()
{
	int n,i,num;
	while(scanf("%d",&n)!=EOF)
	{
		int ans=0;
		int bz=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&num);
			if(num>1)//注意
			bz=1;
			ans^=num;
		}
		if(bz==0)
		{
			if(ans)//其实也可以不用检验ans
			{
				printf(n%2?"No\n":"Yes\n");//注意
			}
			else
			printf("Yes\n");
		}
		else
		{
			printf(ans?"Yes\n":"No\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值