hdoj 1506 Largest Rectangle in a Histogram 【单调栈】

题目链接:hdoj 1506 Largest Rectangle in a Histogram

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15601 Accepted Submission(s): 4542

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000

题意:有n根柱子,要求你找到一个最大的矩形覆盖柱子(覆盖处不能为空),问你最大的矩形面积。

思路:考虑以每根柱子 i i i的高度为矩阵的高,这样若后面的柱子 j j j小于它的高度,说明向右最多只能延伸到 j − 1 j-1 j1,这样维护一个单调递增的栈即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#define CLR(a, b) memset(a, (b), sizeof(a))
#define fi first
#define se second
using namespace std;
typedef long long LL;
typedef pair<int, int> pii;
const int MAXN = 1e5 +10;
const int INF = 0x3f3f3f3f;
pii a[MAXN], Stack[MAXN];
int main()
{
    int n;
    while(scanf("%d", &n), n) {
        LL ans = 0, top = 0; int l, r = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i].fi); a[i].se = i;
            r = 0;
            while(top && Stack[top-1].fi >= a[i].fi) {
                if(r == 0) r = Stack[top-1].se;
                if(top == 1) {
                    l = Stack[top-1].se;
                }
                else {
                    l = Stack[top-1].se - Stack[top-2].se;
                }
                ans = max(ans, 1LL * (l + r - Stack[top-1].se) * Stack[top-1].fi);
                top--;
            }
            Stack[top++] = a[i];
        }
        r = 0;
        while(top) {
            if(r == 0) r = Stack[top-1].se;
            if(top == 1) {
                l = Stack[top-1].se;
            }
            else {
                l = Stack[top-1].se - Stack[top-2].se;
            }
            ans = max(ans, 1LL * (l + r - Stack[top-1].se) * Stack[top-1].fi);
            top--;
        }
        printf("%lld\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值