POJ 3067 Japan

Japan

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24250Accepted: 6552

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

题意是有n座在东边的城市,m座在西边的城市,给定若干组道路,连接东西的城市,求解道路交叉的个数。

这个题可以先按照东边的城市进行排序,对每次城市的添加,使交叉数加上添加的次数减去与之未交叉的个数即1到第n - 1次添加的道路交叉的个数。然后更新树状数组即可。代码如下:

/*************************************************************************
	> File Name: Japan.cpp
	> Author: Zhanghaoran
	> Mail: chilumanxi@xiyoulinux.org
	> Created Time: 2016年02月01日 星期一 18时04分13秒
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;
const int Max = 1000010;
int T;
long k;
int n, m;
long long tree[1010];
long long ans;
struct node{
    int x, y;
}num[1000010];
bool cmp(node a, node b){
    if(a.x == b.x){
        return a.y < b.y;
    }
    else
        return a.x < b.x;
}

void add(int x){
    while(x < 1010){
        tree[x] ++;
        x += x & -x;
    }
}

long long check(int x){
    long long sum = 0;
    while(x){
        sum += tree[x];
        x -= x & -x;
    }
    return sum;
}
int main(void){
    cin >> T;
    int ca = 0;
    while(T --){
	    ca ++;
        ans = 0;
        cin >> n >> m >> k;
        memset(tree, 0, sizeof(tree));  
        for(int i = 0; i < k; i ++){
            scanf("%d %d", &num[i].x, &num[i].y);
        }
        sort(num, num + k, cmp);
        for(int i = 0; i < k; i ++){
            ans += i - check(num[i].y);
            add(num[i].y);
        }
        printf("Test case %d: %lld\n", ca, ans);
    }
    return 0;
}

 

查看原文:http://chilumanxi.org/2016/02/01/poj-3067-japan/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值