POJ - 1228 Grandpa's Estate (稳定凸包 )

Grandpa's Estate

 

Being the only living descendant of his grandfather, Kamran the Believer inherited all of the grandpa's belongings. The most valuable one was a piece of convex polygon shaped farm in the grandpa's birth village. The farm was originally separated from the neighboring farms by a thick rope hooked to some spikes (big nails) placed on the boundary of the polygon. But, when Kamran went to visit his farm, he noticed that the rope and some spikes are missing. Your task is to write a program to help Kamran decide whether the boundary of his farm can be exactly determined only by the remaining spikes.

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains an integer n (1 <= n <= 1000) which is the number of remaining spikes. Next, there are n lines, one line per spike, each containing a pair of integers which are x and y coordinates of the spike.

Output

There should be one output line per test case containing YES or NO depending on whether the boundary of the farm can be uniquely determined from the input.

Sample Input

1
6 
0 0
1 2
3 4
2 0
2 4 
5 0

Sample Output

NO

题目链接:
题目大意:给n个点,求凸包,然后判断此凸包是否是稳定凸包

思路:稳定凸包:凸包的所有边上点的个数都大于2,先求凸包,后判断凸包上是否存在一条边只有两个端点

代码:
 

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
#define ll long long
const double pi=acos(-1.0);
const int N=10010;
struct node
{
    ll x,y;
} e[N],s[N],a[N];
bool cmp(node a,node b)
{
    if(a.y==b.y) return a.x<b.x;
    return a.y<b.y;
}
ll cross(node a,node b,node c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
ll dot(node a,node b,node c)
{
    return (b.x-a.x)*(c.x-a.x)+(b.y-a.y)*(c.y-a.y);
}
double dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp1(node a,node b)
{
    ll mm=cross(e[0],a,b);
    if(mm>0) return 1;
    else if(mm==0&&dis(e[0],a)-dis(e[0],b)<=0)
        return 1;
    else return 0;
}
int n,tot;
void graham()
{
    sort(e,e+n,cmp);
    a[0]=e[0];
    int l=1;
    for(int i=1; i<n; i++)
    {
        if(e[i].x==e[i-1].x&&e[i].y==e[i-1].y) continue;
        a[l++]=e[i];
    }
    n=l;
    if(n<3){tot=n-1;return;}
    sort(a+1,a+n,cmp1);
    s[0]=a[0],s[1]=a[1];
    tot=1;
    for(int i=2; i<n; i++)
    {
        while(tot&&cross(s[tot-1],s[tot],a[i])<0)
            tot--;
        s[++tot]=a[i];
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%lld%lld",&e[i].x,&e[i].y);
        if(n<6) printf("NO\n");
        else
        {
            graham();
            int flag=0;
            for(int i=1; i<tot; i++)
            {
                if(cross(s[i-1],s[i],s[i+1])!=0&&cross(s[i],s[i+1],s[i+2])!=0)
                {
                    flag=1;
                    break;
                }
            }
            if(flag) printf("NO\n");
            else printf("YES\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值