hdu_3183_A Magic Lamp(RMQ+鸽巢原理)

2 篇文章 0 订阅

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3142    Accepted Submission(s): 1241


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

Recommend
lcy

初识RMQ问题的ST算法,这道题还用了抽屉原理。值得注意的地方有<<的运算符顺序,也就是记得加括号。。。还有当我们找到两个位置的数字大小一样时,选择位置靠后那个
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define Si(a) scanf("%d",&a)
#define Sl(a) scanf("%lld",&a)
#define Sd(a) scanf("%lf",&a)
#define Ss(a) scanf("%s",a)
#define Pi(a) printf("%d\n",(a))
#define Pl(a) printf("%lld\n",(a))
#define Pd(a) printf("%lf\n",(a))
#define Ps(a) printf("%s\n",(a))
#define W(a) while(a--)
#define mem(a,b) memset(a,(b),sizeof(a))
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int f[maxn][maxn];

char a[maxn];
char ans[maxn];
int n;

int mymin(int i,int j)
{
    if(a[i]<=a[j])return i;
    else return j;
}

void ST()
{
    for(int i=0;i<n;i++)
    {
        f[i][0]=i;
    }
    int m=(int)(log((double)n)/log(2.0));
    for(int j=1;j<=m;j++)
    {
        for(int i=0;i+(1<<j)-1<n;i++)
        {
            f[i][j]=mymin(f[i][j-1],f[i+(1<<(j-1))][j-1]);
        }
    }
}

int query(int l,int r)
{
    int x=(int)(log((double)(r-l+1))/log(2.0));
    return mymin(f[l][x],f[r-(1<<x)+1][x]);
}


int main()
{
    int m;
    while(~scanf("%s%d",a,&m))
    {
        n=strlen(a);
        int len=n-m;
        ST();
        int i=0,j=0;
        while(len--)
        {
            i=query(i,n-len-1);
            ans[j++]=a[i++];
        }
        for(i=0;i<j;i++)
        {
            if(ans[i]!='0')break;
        }
        if(i==j)
        {
            printf("0\n");
            mem(ans,'\0');
            continue;
        }
        printf("%s\n",ans+i);
        mem(ans,'\0');
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值