poj_2965 The Pilots Brothers' refrigerator(bfs+位运算)

16 篇文章 0 订阅
7 篇文章 0 订阅
The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24547 Accepted: 9461 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4
 
使用了跟之前做poj1753一样的思路,用16位的整数保存状态。不过这道题它要保存路径,这里我用了一个结构体数组,
pre保存达到该状态的前一个状态,val保存其操作的冰箱位置。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1<<16
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

struct p{
    int pre;
    int val;
}state[maxn];

queue<int> Q;
int step[maxn];
bool vis[maxn];
bool flag = false;
int ans;
vector<int> ansq;

void bfs(int n)
{
    if(n == (1<<16) - 1){
        ans = 0;
        flag = true;
        return;
    }
    Q.push(n);
    step[n] = 0;
    state[n].pre = -1;
    state[n].val = -1;
    vis[n] = true;
    while(!Q.empty()){
        int temp = Q.front();
        //printf("%d\n", temp);
        Q.pop();
        for(int i = 0; i < 16; i++){
            int t = temp;

            t ^= 15 << ((3 - i/4) * 4);
            if(i <= 3){
                t ^= 1 << (15 - i - 4);
                t ^= 1 << (15 - i - 8);
                t ^= 1 << (15 - i - 12);
            } else if(i >= 12){
                t ^= 1 << (15 - i + 4);
                t ^= 1 << (15 - i + 8);
                t ^= 1 << (15 - i + 12);
            } else {
                t ^= 1 << (15 - i - 4);
                t ^= 1 << (15 - i + 4);
                if(i < 8) t ^= 1 << (15 - i - 8);
                else t ^= 1 << (15 - i + 8);
            }

            if(t == (1<<16) - 1){
                ans = step[temp] + 1;
                state[t].pre = temp;
                state[t].val = i;

                while(state[t].val != -1) {
                    ansq.push_back(state[t].val);
                    t = state[t].pre;
                }

                flag = true;
                return ;
            }

            if(!vis[t]){
                vis[t] = true;
                Q.push(t);
                step[t] = step[temp] + 1;
                state[t].pre = temp;
                state[t].val = i;
            }
        }
    }
}

int main()
{

    int id = 0;
    char s[10];
    for(int i = 0; i < 4; i++)
    {
        scanf("%s", s);
        for(int i = 0; i < 4; i++){
            id <<= 1;
            if(s[i] == '-')id++;
        }
    }
    bfs(id);
    if(flag){
        printf("%d\n", ans);
        for(int i = ansq.size() - 1; i >= 0; i--){
            printf("%d %d\n", ansq[i] / 4 + 1, ansq[i] % 4 + 1);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值